tint2: Use custom config file. This enables launcher and multidesktop support.
authorMichael Büsch <mb@bu3sch.de>
Fri, 28 Jan 2011 13:00:18 +0000 (13:00 +0000)
committerMichael Büsch <mb@bu3sch.de>
Fri, 28 Jan 2011 13:00:18 +0000 (13:00 +0000)
SVN-Revision: 25197

desktop/apps/tint2/Makefile
desktop/apps/tint2/files/tint2rc [new file with mode: 0644]

index 54a781d075cfa84fc256e35f2b45294f302b8e54..ee611021580a0d443f00f4654456671141e2bfe4 100644 (file)
@@ -72,7 +72,7 @@ endef
 
 define Package/tint2/install
        $(INSTALL_DIR) $(1)/usr/bin $(1)/usr/share $(1)/etc/xdg/tint2
-       $(CP) $(PKG_INSTALL_DIR)/etc/xdg/tint2/* $(1)/etc/xdg/tint2/
+       $(CP) ./files/tint2rc $(1)/etc/xdg/tint2/
        $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
        $(CP) $(PKG_INSTALL_DIR)/usr/share/* $(1)/usr/share/
 endef
diff --git a/desktop/apps/tint2/files/tint2rc b/desktop/apps/tint2/files/tint2rc
new file mode 100644 (file)
index 0000000..ceb4306
--- /dev/null
@@ -0,0 +1,127 @@
+# Tint2 config file
+# For information on manually configuring tint2 see http://code.google.com/p/tint2/wiki/Configure
+
+# Background definitions
+# ID 1
+rounded = 7
+border_width = 2
+background_color = #000000 60
+border_color = #FFFFFF 16
+
+# ID 2
+rounded = 5
+border_width = 0
+background_color = #FFFFFF 40
+border_color = #FFFFFF 48
+
+# ID 3
+rounded = 5
+border_width = 0
+background_color = #FFFFFF 16
+border_color = #FFFFFF 68
+
+# Panel
+panel_monitor = all
+panel_position = bottom center horizontal
+panel_size = 100% 30
+panel_margin = 0 0
+panel_padding = 7 0 7
+panel_dock = 0
+wm_menu = 0
+panel_layer = top
+panel_background_id = 1
+panel_items = LTSCB
+
+# Panel Autohide
+autohide = 0
+autohide_show_timeout = 0.3
+autohide_hide_timeout = 2
+autohide_height = 2
+strut_policy = follow_size
+
+# Taskbar
+taskbar_mode = multi_desktop
+taskbar_padding = 2 3 2
+taskbar_background_id = 0
+taskbar_active_background_id = 0
+
+# Launcher
+#launcher_icon_theme = foo
+launcher_padding = 2 3 2
+launcher_background_id = 0
+launcher_icon_size = 16
+launcher_item_app = /usr/share/applications/xterm.desktop
+launcher_item_app = /usr/share/applications/dillo.desktop
+#launcher_item_app = /usr/share/applications/ADD_MY_APPLICATION_HERE.desktop
+
+# Tasks
+urgent_nb_of_blink = 8
+task_icon = 1
+task_text = 1
+task_centered = 1
+task_maximum_size = 140 35
+task_padding = 6 2
+task_background_id = 3
+task_active_background_id = 2
+task_urgent_background_id = 2
+task_iconified_background_id = 3
+task_tooltip = 0
+
+# Task Icons
+task_icon_asb = 70 0 0
+task_active_icon_asb = 100 0 0
+task_urgent_icon_asb = 100 0 0
+task_iconified_icon_asb = 70 0 0
+
+# Fonts
+task_font = sans 7
+task_font_color = #FFFFFF 68
+task_active_font_color = #FFFFFF 83
+task_urgent_font_color = #FFFFFF 83
+task_iconified_font_color = #FFFFFF 68
+font_shadow = 0
+
+# System Tray
+systray = 1
+systray_padding = 0 4 5
+systray_sort = ascending
+systray_background_id = 0
+systray_icon_size = 16
+systray_icon_asb = 70 0 0
+
+# Clock
+time1_format = %H:%M
+time1_font = sans 8
+time2_format = %A %d %B
+time2_font = sans 6
+clock_font_color = #FFFFFF 74
+clock_padding = 1 0
+clock_background_id = 0
+clock_rclick_command = orage
+
+# Tooltips
+tooltip_padding = 2 2
+tooltip_show_timeout = 0.7
+tooltip_hide_timeout = 0.3
+tooltip_background_id = 1
+tooltip_font = sans 10
+tooltip_font_color = #000000 80
+
+# Mouse
+mouse_middle = none
+mouse_right = close
+mouse_scroll_up = toggle
+mouse_scroll_down = iconify
+
+# Battery
+battery = 0
+battery_low_status = 10
+battery_low_cmd = notify-send "battery low"
+battery_hide = 98
+bat1_font = sans 8
+bat2_font = sans 6
+battery_font_color = #FFFFFF 74
+battery_padding = 1 0
+battery_background_id = 0
+
+# End of config