added argtables, signed off by michu-at-neophobdotcom
authorJohn Crispin <john@openwrt.org>
Fri, 28 Dec 2007 14:57:36 +0000 (14:57 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 28 Dec 2007 14:57:36 +0000 (14:57 +0000)
SVN-Revision: 9980

libs/confuse/Makefile [new file with mode: 0644]

diff --git a/libs/confuse/Makefile b/libs/confuse/Makefile
new file mode 100644 (file)
index 0000000..b61a8df
--- /dev/null
@@ -0,0 +1,73 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 9349 2007-10-18 18:46:37Z blogic $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=confuse
+PKG_VERSION:=2.5
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://download.savannah.gnu.org/releases/confuse/
+PKG_MD5SUM:=4bc9b73d77ebd571ac834619ce0b3582
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/confuse
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=libConfuse is a configuration file parser library
+  URL:=http://www.nongnu.org/confuse/
+endef
+
+define Package/confuse/description
+        libConfuse is a configuration file parser library, licensed under the terms of the LGPL, 
+        and written in C. It supports sections and (lists of) values (strings, integers, floats, 
+        booleans or other sections), as well as some other features (such as single/double-quoted
+        strings, environment variable expansion, functions and nested include statements). It makes 
+        it very easy to add configuration file capability to a program using a simple API.
+        
+        The goal of libConfuse is not to be the configuration file parser library with a gazillion 
+        of features. Instead, it aims to be easy to use and quick to integrate with your code. 
+        libConfuse was called libcfg before, but was changed to not confuse with other similar libraries. 
+endef
+
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --without-libiconv-prefix \                                                                                                                           --without-libintl-prefix \
+
+MAKE_FLAGS += \
+       -C $(PKG_BUILD_DIR)/src \
+       DESTDIR="$(PKG_INSTALL_DIR)" \
+       all install \
+
+define Build/InstallDev
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/confuse.h $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfuse.{a,so*} $(1)/usr/lib/
+       $(CP) $(PKG_BUILD_DIR)/*.pc $(1)/usr/lib/pkgconfig/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+       $(STAGING_DIR)/usr/include/confuse.h \
+       $(STAGING_DIR)/usr/lib/libconfuse.{a,so*}
+endef          
+
+define Package/confuse/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfuse.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,confuse))