[packages] olsrd: allow pipe signs for service descriptions in olsr init script;...
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 3 Aug 2009 18:35:48 +0000 (18:35 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 3 Aug 2009 18:35:48 +0000 (18:35 +0000)
SVN-Revision: 17106

net/olsrd/Makefile
net/olsrd/files/olsrd.init

index 9b23d20700458e024f01e3468f8e03bcbac534e8..802c548f5988a82d3e80675bc2b7a23c6dde143b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=olsrd
 PKG_VERSION:=0.5.6-r5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.olsr.org/releases/0.5
index f719c4546f807d184059886a111936a93e9192c1..4cc4e4283e6b3a594b6eee68781167fe609276fb 100644 (file)
@@ -26,7 +26,7 @@ validate_ifname() {
 
 validate_olsrd_option() {
        local str="$1"
-       [ -z "$str" -o "$str" != "${str%%[!     0-9A-Za-z./:_-]*}" ] && return 1
+       [ -z "$str" -o "$str" != "${str%%[!     0-9A-Za-z./|:_-]*}" ] && return 1
        return 0
 }