mpd update to 0.13.0 (fix #2187)
authorJens Muecke <jens@nons.de>
Fri, 10 Aug 2007 12:48:32 +0000 (12:48 +0000)
committerJens Muecke <jens@nons.de>
Fri, 10 Aug 2007 12:48:32 +0000 (12:48 +0000)
SVN-Revision: 8386

sound/mpd/Makefile

index 51b716fe8acd49e018bb896e0e6fa91401d167c9..144c811c4e3116de201848498b8986175a6ad31a 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpd
-PKG_VERSION:=0.12.0
+PKG_VERSION:=0.13.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
-PKG_MD5SUM:=65e62cc813f2186dff0f96f164a853f8
+PKG_SOURCE_URL:=http://www.musicpd.org/uploads/files/
+PKG_MD5SUM:=0b33bdb9d706439949344073e90f812a
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -44,22 +44,21 @@ endif
 
 define Build/Configure
        $(call Build/Configure/Default, \
-               $(EXTRA_CONFIG_PARAM) \
+               $(EXTRA_CONFIG_PARAM) \
                --disable-shout \
-               --disable-mod \
-               --disable-audiofile \
-               --disable-iconv \
-               --disable-mpc \
-               --disable-aac \
-               --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
-               --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
-               --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-mad-includes="$(STAGING_DIR)/usr/include" \
-               --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
-               --with-tremor \
-               --with-tremor-includes="$(STAGING_DIR)/usr/include" \
-               --with-tremor-libraries="$(STAGING_DIR)/usr/lib" \
+               --disable-mod \
+               --disable-audiofile \
+               --disable-iconv \
+               --disable-mpc \
+               --disable-aac \
+               --disable-oggvorbis \
+               --disable-oggflac \
+               --with-id3tag-includes="$(STAGING_DIR)/usr/include" \
+               --with-id3tag-libraries="$(STAGING_DIR)/usr/lib" \
+               --with-libFLAC-includes="$(STAGING_DIR)/usr/include" \
+               --with-libFLAC-libraries="$(STAGING_DIR)/usr/lib" \
+               --with-mad-includes="$(STAGING_DIR)/usr/include" \
+               --with-mad-libraries="$(STAGING_DIR)/usr/lib" \
        )
 endef