[PATCH] [package] pcmciautils: fix pccardctl segfault
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:57:27 +0000 (15:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:57:27 +0000 (15:57 +0000)
Signed-off-by: Erik Inge Bols? <knan-openwrt@anduin.net>
SVN-Revision: 15265

utils/pcmciautils/Makefile

index 8346c2a838a8fd1bedc0842f8a8c628df5be71ea..e54fb618f9bcc98b08c4a78582ebde76a6ab9de6 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=pcmciautils
 PKG_VERSION:=015
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/utils/kernel/pcmcia/
@@ -31,7 +31,7 @@ define Build/Compile
        $(call Build/Compile/Default, \
                LD="$(TARGET_CC)" UDEV=false \
                CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) \
-               -DPCMCIAUTILS_VERSION=$(PKG_VERSION)" \
+               -DPCMCIAUTILS_VERSION=\\\"$(PKG_VERSION)\\\"" \
                prefix=/usr all \
        )
 endef