[packages] radvd: use "::/64" placeholder for empty prefixes in interface sections...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Feb 2011 17:30:56 +0000 (17:30 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Feb 2011 17:30:56 +0000 (17:30 +0000)
SVN-Revision: 25424

ipv6/radvd/Makefile
ipv6/radvd/files/radvd.init

index ee95baba456c1162db4ae8c2974d91b3ababd640..a2ec0bc0fc372a65589128a236569b85524d2c51 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
 PKG_VERSION:=1.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
index dbbe52cc8131ca0f0501bc9ae04fd8fbf4a0d6c3..08cd791aad7948fe12570c1b049ccc3edf5a33f1 100644 (file)
@@ -196,11 +196,7 @@ radvd_write_prefix() {
        done
        [ "$exist" -eq 0 ] && return 0
 
-       config_get prefixes "$cfg" prefix
-       if [ -z "$prefixes" ]; then
-               prefixes=$(get_ip6addr "$IFNAME") || return 0
-       fi
-
+       config_get prefixes "$cfg" prefix "::/64"
        for prefix in $prefixes; do
                validate_ip6prefix "$prefix" || continue
                printf '\n\tprefix %s\n\t{\n' "$prefix"