[package] fix kmod-pcmcia-serial for 3.3+ kernels
authorFlorian Fainelli <florian@openwrt.org>
Fri, 27 Apr 2012 16:44:44 +0000 (16:44 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 27 Apr 2012 16:44:44 +0000 (16:44 +0000)
SVN-Revision: 31490

package/kernel/modules/pcmcia.mk

index 48112b081dd51a2222cd835293d952edb40adc64..7ea259923fbe82234b4a572c29ef3c6e9ad5ad4b 100644 (file)
@@ -70,7 +70,11 @@ define KernelPackage/pcmcia-serial
        CONFIG_PCMCIA_SERIAL_CS \
        CONFIG_SERIAL_8250_CS
   ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
-    FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+    ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+       FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
+    else
+       FILES:=$(LINUX_DIR)/drivers/tty/serial/serial_cs.ko
+    endif
   else
     FILES:=$(LINUX_DIR)/drivers/serial/serial_cs.ko
   endif