[target/orion]: upgrade to 2.6.37
authorImre Kaloz <kaloz@openwrt.org>
Mon, 24 Jan 2011 12:51:48 +0000 (12:51 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Mon, 24 Jan 2011 12:51:48 +0000 (12:51 +0000)
SVN-Revision: 25090

target/linux/orion/Makefile
target/linux/orion/files/arch/arm/mach-orion5x/dt2-setup.c
target/linux/orion/patches/200-dt2_board_support.patch

index 8d4bef6b7b0f8d7216e2043a0f0c044c142fd783..2dc5d2530c56e9a42da43c9fdf3c6e2482c3d6f5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.2
+LINUX_VERSION:=2.6.37
 
 include $(INCLUDE_DIR)/target.mk
 
index 8ff23f7dd8c8fd702823c0c572b75bdf4ffbb981..39b7e82e76a3ffb46d434dc7840a7dead5c90c3f 100644 (file)
@@ -437,8 +437,6 @@ void __init openwrt_fixup(struct machine_desc *mdesc, struct tag *t,
 /* Warning: Freecom uses their own custom bootloader with mach-type (=1500) */
 MACHINE_START(DT2, "Freecom DataTank Gateway")
        /* Maintainer: Zintis Petersons <Zintis.Petersons@abcsolutions.lv> */
-       .phys_io        = ORION5X_REGS_PHYS_BASE,
-       .io_pg_offst    = ((ORION5X_REGS_VIRT_BASE) >> 18) & 0xFFFC,
        .boot_params    = 0x00000100,
        .init_machine   = dt2_init,
        .map_io         = orion5x_map_io,
index aa645ea499c9827bd8cd4383b75150f9b08cb1d8..91909abac0b38d350d274451fcd164fda018e8e7 100644 (file)
        select I2C_BOARDINFO
 --- a/arch/arm/mach-orion5x/Makefile
 +++ b/arch/arm/mach-orion5x/Makefile
-@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_WNR854T)   += wnr854t-se
+@@ -18,6 +18,7 @@ obj-$(CONFIG_MACH_BIGDISK)   += d2net-setu
+ obj-$(CONFIG_MACH_NET2BIG)    += net2big-setup.o
+ obj-$(CONFIG_MACH_MSS2)               += mss2-setup.o
+ obj-$(CONFIG_MACH_WNR854T)    += wnr854t-setup.o
++obj-$(CONFIG_MACH_DT2)                += dt2-setup.o
  obj-$(CONFIG_MACH_RD88F5181L_GE)      += rd88f5181l-ge-setup.o
  obj-$(CONFIG_MACH_RD88F5181L_FXO)     += rd88f5181l-fxo-setup.o
  obj-$(CONFIG_MACH_RD88F6183AP_GE)     += rd88f6183ap-ge-setup.o
-+obj-$(CONFIG_MACH_DT2)                += dt2-setup.o