[packages_10.03.2] anyremote: merge r28945, r29199
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:40:26 +0000 (16:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 5 Feb 2012 16:40:26 +0000 (16:40 +0000)
SVN-Revision: 30286

utils/anyremote/Makefile
utils/anyremote/files/anyremote.init

index 2c617dfbf4b8b54cc42736801a6bb8368305b41a..bf2930d37051ebb5395f0ff9474a52173403f2ee 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=anyremote
 PKG_VERSION:=4.7.1
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/${PKG_NAME}
@@ -44,4 +44,8 @@ define Package/anyremote/install
        $(INSTALL_BIN) ./files/anyremote.init $(1)/etc/init.d/anyremote
 endef
 
+define Package/anyremote/conffiles
+/etc/anyremote.cfg
+endef
+
 $(eval $(call BuildPackage,anyremote))
index e32b615090a839491ab50cc8a1e59c5e8e367d12..af05f499a07eb2c2c0dc2d4cedbd8b3de58a2c29 100644 (file)
@@ -1,13 +1,15 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
+
 START=95
 
+SERVICE_DAEMONIZE=1
+SERVICE_WRITE_PID=1
+
 start() {
-    /usr/sbin/anyremote -f /etc/anyremote.cfg > /dev/null &
+       service_start /usr/sbin/anyremote -f /etc/anyremote.cfg
 }
-    
+
 stop() {
-    killall anyremote
+       service_stop /usr/sbin/anyremote
 }
-       
-