merge r15058 to 8.09 (closes: #4839), bump release number
authorNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 12:31:50 +0000 (12:31 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 10 Apr 2009 12:31:50 +0000 (12:31 +0000)
SVN-Revision: 15199

package/wpa_supplicant/Makefile
package/wpa_supplicant/files/wpa_supplicant.sh

index ed6e45588e6bf66521974e1f6190c98ccfd3503b..5319e5a4755e354da9cf6fd48f34d9c3145f0c4a 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wpa_supplicant
 PKG_VERSION:=0.6.3
 
 PKG_NAME:=wpa_supplicant
 PKG_VERSION:=0.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=b51b2975f21006f85f7297f3fb1acde1
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
 PKG_MD5SUM:=b51b2975f21006f85f7297f3fb1acde1
 
 PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
index 44211b4d4ef2605de107e4ab3039f5182323fd93..0dbb413176c7010d6a91d2f156cfbd49ca812b13 100644 (file)
@@ -32,7 +32,7 @@ wpa_supplicant_setup_vif() {
                        proto='WPA2'
                        key_mgmt='WPA-EAP'
                        config_get ca_cert "$vif" ca_cert
                        proto='WPA2'
                        key_mgmt='WPA-EAP'
                        config_get ca_cert "$vif" ca_cert
-                       ca_cert="ca_cert=\"$ca_cert\""
+                       ca_cert=${ca_cert:+"ca_cert=\"$ca_cert\""}
                        case "$eap_type" in
                                tls|TLS)
                                        pairwise='pairwise=CCMP'
                        case "$eap_type" in
                                tls|TLS)
                                        pairwise='pairwise=CCMP'
@@ -51,17 +51,20 @@ wpa_supplicant_setup_vif() {
                                        password="password=\"$password\""
                                ;;
                        esac
                                        password="password=\"$password\""
                                ;;
                        esac
-                       eap_type="eap_type=$(echo $eap_type | tr 'a-z' 'A-Z')"
+                       eap_type="eap=$(echo $eap_type | tr 'a-z' 'A-Z')"
                ;;
        esac
        config_get ifname "$vif" ifname
        config_get bridge "$vif" bridge
        config_get ssid "$vif" ssid
                ;;
        esac
        config_get ifname "$vif" ifname
        config_get bridge "$vif" bridge
        config_get ssid "$vif" ssid
+       config_get bssid "$vif" bssid
+       bssid=${bssid:+"bssid=$bssid"}
        cat > /var/run/wpa_supplicant-$ifname.conf <<EOF
 ctrl_interface=/var/run/wpa_supplicant-$ifname
 network={
        scan_ssid=1
        ssid="$ssid"
        cat > /var/run/wpa_supplicant-$ifname.conf <<EOF
 ctrl_interface=/var/run/wpa_supplicant-$ifname
 network={
        scan_ssid=1
        ssid="$ssid"
+       $bssid
        key_mgmt=$key_mgmt
        proto=$proto
        $passphrase
        key_mgmt=$key_mgmt
        proto=$proto
        $passphrase