Add fortune-mod (#1493)
authorFlorian Fainelli <florian@openwrt.org>
Fri, 11 May 2007 17:22:36 +0000 (17:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 11 May 2007 17:22:36 +0000 (17:22 +0000)
SVN-Revision: 7187

utils/fortune-mod/Makefile [new file with mode: 0644]

diff --git a/utils/fortune-mod/Makefile b/utils/fortune-mod/Makefile
new file mode 100644 (file)
index 0000000..d48f4d7
--- /dev/null
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=fortune-mod
+PKG_VERSION:=1.2.1
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://freeware.sgi.com/source/fortune-mod
+PKG_MD5SUM:=383b1de06b35450235732c7ae7b5f0e3
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/fortune-mod
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=display fortune cookies on demand.
+  DESCRIPTION:=Fortune mod displays fortune cookies on demand
+  URL:=http://freeware.sgi.com/source/fortune-mod
+endef
+
+define Build/Compile
+       $(HOSTCC) -Wall -o $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/util/strfile.c -DVERSION=\"$(PKG_VERSION)\"
+       $(PKG_BUILD_DIR)/util/strfile-host $(PKG_BUILD_DIR)/datfiles/fortunes $(PKG_BUILD_DIR)/datfiles/fortunes.dat
+       $(MAKE) -C $(PKG_BUILD_DIR)/fortune
+endef
+
+define Package/fortune-mod/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/fortune/fortune $(1)/usr/bin/
+       $(INSTALL_DIR) $(1)/usr/share/games/fortunes
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/datfiles/fortunes $(1)/usr/share/games/fortunes
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/datfiles/fortunes.dat $(1)/usr/share/games/fortunes
+endef
+
+$(eval $(call BuildPackage,fortune-mod))