Reduce the kernel verbosity of the ps3_system_bus_match output
authorYuji Mano <yuji.mano@am.sony.com>
Wed, 28 May 2008 18:57:18 +0000 (18:57 +0000)
committerYuji Mano <yuji.mano@am.sony.com>
Wed, 28 May 2008 18:57:18 +0000 (18:57 +0000)
for ps3 builds.

Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
SVN-Revision: 11282

target/linux/ps3/Makefile
target/linux/ps3/patches-2.6.25/100-ps3-system-bus-quiet-match-output.patch [new file with mode: 0644]

index 14dbc9779680d4c739744cc59988c4fc56b63f53..aacb116ae18f0321ac309edb5f024ebb4df0e31a 100644 (file)
@@ -20,13 +20,10 @@ define Target/Description
        Build bootloader images for the Sony PS3 Game Console
 endef
 
-# no patches required
-define Kernel/Prepare/ps3
-       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
-endef
-
+# no generic patches required
 define Kernel/Prepare
-       $(call Kernel/Prepare/ps3)
+       bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+       $(call PatchDir,$(PATCH_DIR),)
 endef
 
 KERNELNAME:="zImage"
diff --git a/target/linux/ps3/patches-2.6.25/100-ps3-system-bus-quiet-match-output.patch b/target/linux/ps3/patches-2.6.25/100-ps3-system-bus-quiet-match-output.patch
new file mode 100644 (file)
index 0000000..53e88bd
--- /dev/null
@@ -0,0 +1,69 @@
+Subject: PS3: Quiet system bus match output
+
+Reduce the verbosity of the output from ps3_system_bus_match().
+
+Signed-off-by: Geoff Levand <geoffrey.levand@am.sony.com>
+---
+ arch/powerpc/platforms/ps3/system-bus.c |   21 +++++++++++++--------
+ 1 file changed, 13 insertions(+), 8 deletions(-)
+
+--- a/arch/powerpc/platforms/ps3/system-bus.c
++++ b/arch/powerpc/platforms/ps3/system-bus.c
+@@ -349,9 +349,14 @@ static int ps3_system_bus_match(struct d
+       result = dev->match_id == drv->match_id;
+-      pr_info("%s:%d: dev=%u(%s), drv=%u(%s): %s\n", __func__, __LINE__,
+-              dev->match_id, dev->core.bus_id, drv->match_id, drv->core.name,
+-              (result ? "match" : "miss"));
++      if (result)
++              pr_info("%s:%d: dev=%u(%s), drv=%u(%s): match\n", __func__,
++                      __LINE__, dev->match_id, dev->core.bus_id,
++                      drv->match_id, drv->core.name);
++      else
++              pr_debug("%s:%d: dev=%u(%s), drv=%u(%s): miss\n", __func__,
++                      __LINE__, dev->match_id, dev->core.bus_id,
++                      drv->match_id, drv->core.name);
+       return result;
+ }
+@@ -362,7 +367,7 @@ static int ps3_system_bus_probe(struct d
+       struct ps3_system_bus_driver *drv;
+       BUG_ON(!dev);
+-      pr_info(" -> %s:%d: %s\n", __func__, __LINE__, _dev->bus_id);
++      pr_debug(" -> %s:%d: %s\n", __func__, __LINE__, _dev->bus_id);
+       drv = ps3_system_bus_dev_to_system_bus_drv(dev);
+       BUG_ON(!drv);
+@@ -370,10 +375,10 @@ static int ps3_system_bus_probe(struct d
+       if (drv->probe)
+               result = drv->probe(dev);
+       else
+-              pr_info("%s:%d: %s no probe method\n", __func__, __LINE__,
++              pr_debug("%s:%d: %s no probe method\n", __func__, __LINE__,
+                       dev->core.bus_id);
+-      pr_info(" <- %s:%d: %s\n", __func__, __LINE__, dev->core.bus_id);
++      pr_debug(" <- %s:%d: %s\n", __func__, __LINE__, dev->core.bus_id);
+       return result;
+ }
+@@ -384,7 +389,7 @@ static int ps3_system_bus_remove(struct 
+       struct ps3_system_bus_driver *drv;
+       BUG_ON(!dev);
+-      pr_info(" -> %s:%d: %s\n", __func__, __LINE__, _dev->bus_id);
++      pr_debug(" -> %s:%d: %s\n", __func__, __LINE__, _dev->bus_id);
+       drv = ps3_system_bus_dev_to_system_bus_drv(dev);
+       BUG_ON(!drv);
+@@ -395,7 +400,7 @@ static int ps3_system_bus_remove(struct 
+               dev_dbg(&dev->core, "%s:%d %s: no remove method\n",
+                       __func__, __LINE__, drv->core.name);
+-      pr_info(" <- %s:%d: %s\n", __func__, __LINE__, dev->core.bus_id);
++      pr_debug(" <- %s:%d: %s\n", __func__, __LINE__, dev->core.bus_id);
+       return result;
+ }