Upgrade bind to 9.4.1 (#1977)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 9 Sep 2007 18:14:33 +0000 (18:14 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 9 Sep 2007 18:14:33 +0000 (18:14 +0000)
SVN-Revision: 8714

net/bind/Makefile
net/bind/patches/100-cross_compile.patch
net/bind/patches/110-host_build_fix.patch

index 89daeb71d9245d848c67c35d9d07a00bbfe2c9fd..b978d66dee1a82c110c7d725a922c87ea399a2c2 100644 (file)
@@ -9,14 +9,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bind
-PKG_VERSION:=9.3.2-P2
+PKG_VERSION:=9.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
        ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
        http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
-PKG_MD5SUM:=948101be324deb15ff94a5b6a639ea39
+PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -73,8 +73,9 @@ define Package/bind-dig
   TITLE+= DNS excavation tool
 endef
 
-define Package/Build/Configure
-       $(call Build/Configure/Default,\
+export BUILD_CC="$(TARGET_CC)"
+
+CONFIGURE_ARGS += \
                --enable-shared \
                --enable-static \
                --enable-ipv6 \
@@ -82,19 +83,21 @@ define Package/Build/Configure
                --disable-threads \
                --with-openssl="$(STAGING_DIR)/usr" \
                --with-libtool \
-       )
-endef
+               , \
+               BUILD_CC="$(TARGET_CC)" \
 
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR)/lib/dns \
+               BUILD_CC="$(HOSTCC)" \
                CC="$(HOSTCC)" \
                CFLAGS="-O2" \
                LIBS="" \
                gen
        $(MAKE) -C $(PKG_BUILD_DIR) \
        DESTDIR="$(PKG_INSTALL_DIR)" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
                all install
 endef
 
index 7c674d74e6366b50cdf49ae1ff63c50d13697bd2..e0ce7de6dffd7bf93f7c2ada5e3b766fdbf1cc21 100644 (file)
@@ -1,15 +1,8 @@
---- bind-9.3.2-P1/configure    2005-10-21 01:57:38.000000000 +0200
-+++ bind-9.3.2-P1.new/configure        2006-10-16 21:43:12.000000000 +0200
-@@ -4816,7 +4816,7 @@
-   use_openssl="auto"
- fi;
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="-I$STAGING_DIR/usr/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
-@@ -5357,8 +5357,7 @@
+Index: bind-9.4.1/configure
+===================================================================
+--- bind-9.4.1.orig/configure  2007-06-26 21:11:45.000000000 +0200
++++ bind-9.4.1/configure       2007-06-26 21:12:33.000000000 +0200
+@@ -5262,8 +5262,7 @@
  else
    test "$cross_compiling" = yes &&
    { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
@@ -19,7 +12,7 @@
  if test -r "$devrandom"; then
    eval "$as_ac_File=yes"
  else
-@@ -23747,176 +23746,6 @@
+@@ -24165,176 +24164,6 @@
  # which provides some (all?) of the desired functions.
  #
  
  #
  # Look for a 4.4BSD-style sa_len member in struct sockaddr.
  #
---- bind-9.3.2-P1/configure.in 2005-10-21 01:47:25.000000000 +0200
-+++ bind-9.3.2-P1.new/configure.in     2006-10-16 21:36:09.000000000 +0200
-@@ -363,7 +363,7 @@
-                           (Required for DNSSEC)],
-     use_openssl="$withval", use_openssl="auto")
--openssldirs="/usr /usr/local /usr/local/ssl /usr/pkg"
-+openssldirs="$STAGING_DIR/usr/include $STAGING_DIR/include"
- if test "$use_openssl" = "auto"
- then
-       for d in $openssldirs
---- bind-9.3.2-P1/lib/bind/configure   2005-10-14 03:44:50.000000000 +0200
-+++ bind-9.3.2-P1.new/lib/bind/configure       2006-10-16 21:46:45.000000000 +0200
+Index: bind-9.4.1/lib/bind/configure
+===================================================================
+--- bind-9.4.1.orig/lib/bind/configure 2007-06-26 21:11:45.000000000 +0200
++++ bind-9.4.1/lib/bind/configure      2007-06-26 21:12:33.000000000 +0200
 @@ -4461,6 +4461,7 @@
  if eval "test \"\${$as_ac_File+set}\" = set"; then
    echo $ECHO_N "(cached) $ECHO_C" >&6
index 7275d7f3881336ea3953c7abea312a1725e0f87d..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,12 +0,0 @@
-diff -urN bind-9.3.2-P1/lib/dns/Makefile.in bind-9.3.2-P1.new/lib/dns/Makefile.in
---- bind-9.3.2-P1/lib/dns/Makefile.in  2004-12-09 05:07:15.000000000 +0100
-+++ bind-9.3.2-P1.new/lib/dns/Makefile.in      2006-10-16 21:38:46.000000000 +0200
-@@ -156,7 +156,7 @@
-       ./gen -s ${srcdir} > code.h
- gen: gen.c
--      ${CC} ${ALL_CFLAGS} ${LDFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
-+      ${CC} ${ALL_CFLAGS} -o $@ ${srcdir}/gen.c ${LIBS}
- rbtdb64.@O@: rbtdb.c