[package] uhttpd: allow lowercase http header fields (#8513)
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Dec 2010 22:03:34 +0000 (22:03 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 24 Dec 2010 22:03:34 +0000 (22:03 +0000)
SVN-Revision: 24823

package/uhttpd/Makefile
package/uhttpd/src/uhttpd.c

index b639c007b2c00e6b873c73ceb3e644e9f59076bf..a0b7d24ebfb536ca8bd18213cc4a8532afb1bf9f 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=19
+PKG_RELEASE:=20
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := libcyassl liblua
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := libcyassl liblua
index 491452b6349c7fddddb3d6dca54e80d63f0cfca1..2c7755f8da4c5ed5d61aa0ee5d8d02813fc6d7ce 100644 (file)
@@ -339,8 +339,8 @@ static struct http_request * uh_http_header_parse(struct client *cl, char *buffe
                                hdrdata = &buffer[i+2];
                        }
 
                                hdrdata = &buffer[i+2];
                        }
 
-                       /* have no name and found [A-Z], start of name */
-                       else if( !hdrname && isalpha(buffer[i]) && isupper(buffer[i]) )
+                       /* have no name and found [A-Za-z], start of name */
+                       else if( !hdrname && isalpha(buffer[i]) )
                        {
                                hdrname = &buffer[i];
                        }
                        {
                                hdrname = &buffer[i];
                        }