add support Konica based USB video devices
authorNicolas Thill <nico@openwrt.org>
Fri, 21 Sep 2007 13:05:13 +0000 (13:05 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 21 Sep 2007 13:05:13 +0000 (13:05 +0000)
SVN-Revision: 8913

package/kernel/modules/video.mk

index 838c4c5f62b89a09b98f7caebbc67d9525228390..311e5387c627341a04211386df8350e9e196fdf5 100644 (file)
@@ -61,6 +61,23 @@ endef
 $(eval $(call KernelPackage,video-cpia2))
 
 
+define KernelPackage/video-konica
+  SUBMENU:=$(VIDEO_MENU)
+  TITLE:=Konica USB webcam support
+  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core
+  KCONFIG:=CONFIG_USB_KONICAWC
+  FILES:=$(LINUX_DIR)/drivers/media/video/usbvideo/konicawc.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,70,konicawc)
+endef
+
+define KernelPackage/video-konica/description
+ Kernel support for webcams based on a Konica chipset. This is known to 
+ work with the Intel YC76 webcam.
+endef
+
+$(eval $(call KernelPackage,video-konica))
+
+
 define KernelPackage/video-pwc
   SUBMENU:=$(VIDEO_MENU)
   TITLE:=Philips USB webcam support