[packages] tiff: add a tiff-utils subpackage
authorNicolas Thill <nico@openwrt.org>
Thu, 16 Jul 2009 06:22:37 +0000 (06:22 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 16 Jul 2009 06:22:37 +0000 (06:22 +0000)
SVN-Revision: 16855

libs/tiff/Makefile

index 398961b40109930e39b5eb5a7440d91f586607ce..1b24cd0a08bc563567173e51944142d083a97a5e 100644 (file)
@@ -21,12 +21,25 @@ include $(INCLUDE_DIR)/package.mk
 
 PKG_INSTALL=1
 
+define Package/tiff/Default
+  TITLE:=TIFF
+  URL:=http://www.remotesensing.org/libtiff/
+endef
+
 define Package/libtiff
+$(call Package/tiff/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  TITLE:=TIFF libraries
+  TITLE+= libraries
   DEPENDS:=+zlib +libjpeg
-  URL:=http://www.remotesensing.org/libtiff/
+endef
+
+define Package/tiff-utils
+$(call Package/tiff/Default)
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE+= utilities
+  DEPENDS:=+libtiff
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -44,4 +57,10 @@ define Package/libtiff/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib*.so.* $(1)/usr/lib/
 endef
 
+define Package/tiff-utils/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
+endef
+
 $(eval $(call BuildPackage,libtiff))
+$(eval $(call BuildPackage,tiff-utils))