[lantiq] make hcd driver work with v3.8
authorJohn Crispin <john@openwrt.org>
Thu, 14 Mar 2013 18:42:57 +0000 (18:42 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 14 Mar 2013 18:42:57 +0000 (18:42 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 36019

package/platform/lantiq/ltq-hcd/Makefile
package/platform/lantiq/ltq-hcd/src/ifxusb_driver.c

index 6f654b4aa440ce6825fba37349e111734bccf9cf..74218c887b4dd4e095c0e4b1b289b7121ab1f062 100644 (file)
@@ -23,13 +23,14 @@ define KernelPackage/ltq-hcd-template
   VARIANT:=$(1)
   DEPENDS:=@TARGET_lantiq_$(2) +kmod-usb-core
   FILES:=$(PKG_BUILD_DIR)/ltq_hcd_$(1).ko
   VARIANT:=$(1)
   DEPENDS:=@TARGET_lantiq_$(2) +kmod-usb-core
   FILES:=$(PKG_BUILD_DIR)/ltq_hcd_$(1).ko
-  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1))
+  AUTOLOAD:=$(call AutoLoad,50,ltq_hcd_$(1),1)
 endef
 
 KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,ase)
 KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,danube,xway)
 KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,xway)
 KernelPackage/ltq-hcd-vr9=$(call KernelPackage/ltq-hcd-template,vr9,xway)
 endef
 
 KernelPackage/ltq-hcd-ase=$(call KernelPackage/ltq-hcd-template,ase,ase)
 KernelPackage/ltq-hcd-danube=$(call KernelPackage/ltq-hcd-template,danube,xway)
 KernelPackage/ltq-hcd-ar9=$(call KernelPackage/ltq-hcd-template,ar9,xway)
 KernelPackage/ltq-hcd-vr9=$(call KernelPackage/ltq-hcd-template,vr9,xway)
+KernelPackage/ltq-hcd-ar10=$(call KernelPackage/ltq-hcd-template,ar10,xway)
 
 define Build/Prepare
        $(INSTALL_DIR) $(PKG_BUILD_DIR)
 
 define Build/Prepare
        $(INSTALL_DIR) $(PKG_BUILD_DIR)
@@ -49,3 +50,4 @@ $(eval $(call KernelPackage,ltq-hcd-ase))
 $(eval $(call KernelPackage,ltq-hcd-danube))
 $(eval $(call KernelPackage,ltq-hcd-ar9))
 $(eval $(call KernelPackage,ltq-hcd-vr9))
 $(eval $(call KernelPackage,ltq-hcd-danube))
 $(eval $(call KernelPackage,ltq-hcd-ar9))
 $(eval $(call KernelPackage,ltq-hcd-vr9))
+$(eval $(call KernelPackage,ltq-hcd-ar10))
index c30cf449148b5ec6100745cf4fead56ef1c64af5..04346b972f0ab5b08b8ece318ead3ed646b96bb3 100644 (file)
@@ -315,6 +315,8 @@ static int ifxusb_driver_probe(struct platform_device *_pdev)
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx100");
 #elif defined __IS_VR9__
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-xrx200");
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx100");
 #elif defined __IS_VR9__
         np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-xrx200");
+#elif defined __IS_AR10__
+        np = of_find_compatible_node(NULL, NULL, "lantiq,ifxhcd-arx300");
 #endif
        if (!np) {
                dev_err(&_pdev->dev, "failed to find hcd device node\n");
 #endif
        if (!np) {
                dev_err(&_pdev->dev, "failed to find hcd device node\n");