[packages] mail/msmtp: mark /etc/msmtprc as a conffile
authorAndy Boyett <agb@openwrt.org>
Tue, 3 Feb 2009 05:45:25 +0000 (05:45 +0000)
committerAndy Boyett <agb@openwrt.org>
Tue, 3 Feb 2009 05:45:25 +0000 (05:45 +0000)
SVN-Revision: 14381

mail/msmtp/Makefile

index 7ffed387edad6997d119945156ccfcddbb57aa55..b9364d493ad25fa039f582d2c4bc94a85c337ac0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=msmtp
 PKG_VERSION:=1.4.17
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/msmtp
@@ -26,6 +26,10 @@ define Package/msmtp/Default
   URL:=http://msmtp.sourceforge.net/
 endef
 
+define Package/msmtp/Default/conffiles
+/etc/msmtprc
+endef
+
 define Package/msmtp/Default/description
  msmtp is an SMTP client. In the default mode, it transmits a mail to
  an SMTP server (for example at a free mail provider) which does the
@@ -40,6 +44,10 @@ $(call Package/msmtp/Default)
   TITLE+= (with SSL support)
 endef
 
+define Package/msmtp/conffiles
+$(call Package/msmtp/Default/conffiles)
+endef
+
 define Package/msmtp/description
 $(call Package/msmtp/Default/description)
  This package is built with SSL support.
@@ -50,6 +58,10 @@ $(call Package/msmtp/Default)
   TITLE+= (without SSL support)
 endef
 
+define Package/msmtp-nossl/conffiles
+$(call Package/msmtp/Default/conffiles)
+endef
+
 define Package/msmtp-nossl/description
 $(call Package/msmtp/Default/description)
  This package is built without SSL support.