Add a zyxel prestige profile for the adm5120eb target, build the hcd driver as a...
authorFlorian Fainelli <florian@openwrt.org>
Thu, 2 Aug 2007 13:53:23 +0000 (13:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 2 Aug 2007 13:53:23 +0000 (13:53 +0000)
SVN-Revision: 8317

package/kernel/modules/usb.mk
target/linux/adm5120eb-2.6/config/default
target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk [new file with mode: 0644]
target/linux/adm5120eb-2.6/profiles/100-Texas.mk

index 32a1457248a43d21a38e6494fe985b8ccaada1fa..6d2545a31069e284102e6916b6d96c00f62252b1 100644 (file)
@@ -90,6 +90,16 @@ define KernelPackage/usb-ohci/2.6
 endef
 $(eval $(call KernelPackage,usb-ohci))
 
+define KernelPackage/usb-adm5120
+  $(call usbdep,@LINUX_2_6_ADM5120||@LINUX_2_6_ADM5120EB)
+  TITLE:=Support for the ADM5120 HCD controller
+  DESCRIPTION:=Kernel support for the ADM5120 HCD USB controller
+  KCONFIG:=CONFIG_USB_ADM5120_HCD
+  FILES:=$(LINUX_DIR)/drivers/usb/host/adm5120-hcd.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,adm5120-hcd)
+endef
+$(eval $(call KernelPackage,usb-adm5120))
+
 define KernelPackage/usb2
   $(call usbdep,)
   TITLE:=Support for USB2 controllers
index 9b1daa2c418babf1b8941062bb9854b69e2581f0..05de7eee60461bdfe952309ce556cacf2cfa2662 100644 (file)
@@ -241,7 +241,7 @@ CONFIG_TRAD_SIGNALS=y
 CONFIG_USB=y
 # CONFIG_USBPCWATCHDOG is not set
 # CONFIG_USB_ACM is not set
-CONFIG_USB_ADM5120_HCD=y
+CONFIG_USB_ADM5120_HCD=m
 # CONFIG_USB_ATM is not set
 # CONFIG_USB_CATC is not set
 # CONFIG_USB_DEVICEFS is not set
diff --git a/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk b/target/linux/adm5120eb-2.6/profiles/090-Zyxel.mk
new file mode 100644 (file)
index 0000000..b0741e8
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Zyxel
+  NAME:=Zyxel Prestige P-334/335/335-WT (default)
+  PACKAGES:=kmod-acx kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/Zyxel/Description
+       Package set compatible with the Zyxel prestige P-334/335/335-WT boards
+endef
+$(eval $(call Profile,Zyxel))
+
index a9306ca702563030f598b7dd0199ddbd0d6bc252..727a0c06489094b8c20f8fe5f02cca0f7f6ce81d 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 define Profile/Texas
-  NAME:=Texas Instruments WiFi (default)
+  NAME:=Texas Instruments WiFi
   PACKAGES:=kmod-acx
 endef