Update darkstat to 3.0.708 (#2885)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 24 Jul 2008 10:37:30 +0000 (10:37 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 24 Jul 2008 10:37:30 +0000 (10:37 +0000)
SVN-Revision: 11915

net/darkstat/Makefile
net/darkstat/files/darkstat.init

index ce632335948733f4702b7f81fd9f969ff1165e5f..2f2a7d174b1bfea77efbf034edac98a2b20a4b1d 100644 (file)
@@ -9,15 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=darkstat
-PKG_VERSION:=3.0.707
+PKG_VERSION:=3.0.708
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://dmr.ath.cx/net/darkstat
-PKG_MD5SUM:=91c70f96498dd679b21330214361e4dc
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=21fe231f6ec84be082e9d41747dd0fc9
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -30,7 +27,9 @@ define Package/darkstat
 endef
 
 define Package/darkstat/description
-       A free open source utility for bandwith monitoring \    over web
+       darkstat is a packet sniffer that runs as a background process on a
+       cable/DSL router, gathers all sorts of statistics about network usage,
+       and serves them over HTTP.
 endef
 
 CONFIGURE_ARGS += \
index ac45abf6d4a0bb1fb6d435e4d8bb86d4a322ec45..4f322688afc25dfcf01896ffd311451f29aa99a7 100644 (file)
@@ -22,9 +22,10 @@ start_darkstat() {
        scan_interfaces
        config_get ifname "$interface" ifname
 
-       $BIN --debug -i "$interface" \  
-               ${httpaddr:+-b "$httpaddr"}  \
-               ${httpport:+-p "$httpport"}
+       $BIN --debug -i "$interface" \
+               ${httpaddr:+-b "$httpaddr"} \
+               ${httpport:+-p "$httpport"} \
+               --chroot $RUN_D
 }