packages/p910nd: rename uci config file, cleanup
authorNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 11:49:01 +0000 (11:49 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 17 Nov 2011 11:49:01 +0000 (11:49 +0000)
SVN-Revision: 29227

net/p910nd/Makefile
net/p910nd/files/p910nd.conf [deleted file]
net/p910nd/files/p910nd.config [new file with mode: 0644]

index 1e0fafb45f9403c9b4cc19f9e9019b0a4c6e6dd7..7b0b957a604704a838f76552e15615f72bd0c278 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=p910nd
 PKG_VERSION:=0.95
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/p910nd
@@ -45,11 +45,11 @@ MAKE_FLAGS += \
 
 define Package/p910nd/install
        $(INSTALL_DIR) $(1)/usr/sbin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/$(PKG_NAME) $(1)/usr/sbin/
+       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/p910nd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/$(PKG_NAME).conf $(1)/etc/config/$(PKG_NAME)
+       $(INSTALL_DATA) ./files/p910nd.config $(1)/etc/config/p910nd
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_BIN) ./files/p910nd.init $(1)/etc/init.d/p910nd
 endef
 
 $(eval $(call BuildPackage,p910nd))
diff --git a/net/p910nd/files/p910nd.conf b/net/p910nd/files/p910nd.conf
deleted file mode 100644 (file)
index 57a3058..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config p910nd
-       option device        /dev/lp0
-       option port          0
-       option bidirectional 1
-       option enabled       0
diff --git a/net/p910nd/files/p910nd.config b/net/p910nd/files/p910nd.config
new file mode 100644 (file)
index 0000000..57a3058
--- /dev/null
@@ -0,0 +1,5 @@
+config p910nd
+       option device        /dev/lp0
+       option port          0
+       option bidirectional 1
+       option enabled       0