[Packages] admin/htop: Update to 0.8
authorOliver Ertl <oliver@ertl-net.net>
Thu, 8 May 2008 11:33:35 +0000 (11:33 +0000)
committerOliver Ertl <oliver@ertl-net.net>
Thu, 8 May 2008 11:33:35 +0000 (11:33 +0000)
SVN-Revision: 11074

admin/htop/Makefile
admin/htop/patches/001_remove_proc_check.patch [deleted file]

index a6743af6398b8914057e95ba66f41cd832f0f0a2..aca819a471315580bd74edce211b1bc222c73a3e 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=htop
-PKG_VERSION:=0.7
+PKG_VERSION:=0.8
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
-PKG_MD5SUM:=4afc961fa709167e1b434682897991f9
+PKG_MD5SUM:=b6955f8d75cdb5a3ccea83415cb18815
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,6 +32,10 @@ define Package/htop/description
  see all processes and their full command lines. 
 endef
 
+CONFIGURE_VARS += \
+       ac_cv_file__proc_stat=yes \
+       ac_cv_file__proc_meminfo=yes \
+
 define Package/htop/install    
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/bin/
diff --git a/admin/htop/patches/001_remove_proc_check.patch b/admin/htop/patches/001_remove_proc_check.patch
deleted file mode 100644 (file)
index 6400214..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-Index: htop-0.7/configure
-===================================================================
---- htop-0.7.orig/configure    2008-05-07 20:52:47.000000000 +0200
-+++ htop-0.7/configure 2008-05-07 20:52:47.000000000 +0200
-@@ -5844,61 +5844,6 @@
- fi
--as_ac_File=`echo "ac_cv_file_$PROCDIR/stat" | $as_tr_sh`
--{ echo "$as_me:$LINENO: checking for $PROCDIR/stat" >&5
--echo $ECHO_N "checking for $PROCDIR/stat... $ECHO_C" >&6; }
--if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
--  echo $ECHO_N "(cached) $ECHO_C" >&6
--else
--  test "$cross_compiling" = yes &&
--  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
--   { (exit 1); exit 1; }; }
--if test -r "$PROCDIR/stat"; then
--  eval "$as_ac_File=yes"
--else
--  eval "$as_ac_File=no"
--fi
--fi
--ac_res=`eval echo '${'$as_ac_File'}'`
--             { echo "$as_me:$LINENO: result: $ac_res" >&5
--echo "${ECHO_T}$ac_res" >&6; }
--if test `eval echo '${'$as_ac_File'}'` = yes; then
--  :
--else
--  { { echo "$as_me:$LINENO: error: Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&5
--echo "$as_me: error: Cannot find /proc/stat. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&2;}
--   { (exit 1); exit 1; }; }
--fi
--
--as_ac_File=`echo "ac_cv_file_$PROCDIR/meminfo" | $as_tr_sh`
--{ echo "$as_me:$LINENO: checking for $PROCDIR/meminfo" >&5
--echo $ECHO_N "checking for $PROCDIR/meminfo... $ECHO_C" >&6; }
--if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
--  echo $ECHO_N "(cached) $ECHO_C" >&6
--else
--  test "$cross_compiling" = yes &&
--  { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
--echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
--   { (exit 1); exit 1; }; }
--if test -r "$PROCDIR/meminfo"; then
--  eval "$as_ac_File=yes"
--else
--  eval "$as_ac_File=no"
--fi
--fi
--ac_res=`eval echo '${'$as_ac_File'}'`
--             { echo "$as_me:$LINENO: result: $ac_res" >&5
--echo "${ECHO_T}$ac_res" >&6; }
--if test `eval echo '${'$as_ac_File'}'` = yes; then
--  :
--else
--  { { echo "$as_me:$LINENO: error: Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&5
--echo "$as_me: error: Cannot find /proc/meminfo. Make sure you have a Linux-compatible /proc filesystem mounted. See the file README for help." >&2;}
--   { (exit 1); exit 1; }; }
--fi
--
--
- ac_config_files="$ac_config_files Makefile"
- cat >confcache <<\_ACEOF