add a losetup package, cosmetic fixes on package descriptions
authorNicolas Thill <nico@openwrt.org>
Tue, 29 Nov 2005 11:13:32 +0000 (11:13 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 29 Nov 2005 11:13:32 +0000 (11:13 +0000)
SVN-Revision: 2567

openwrt/package/util-linux/Config.in
openwrt/package/util-linux/Makefile
openwrt/package/util-linux/ipkg/fdisk.control
openwrt/package/util-linux/ipkg/losetup.control [new file with mode: 0644]

index 9f1c3a7f97dd0b71cae40b4d0cd5fb2b8bb6c7f8..8faceb6e7ccecfb119bd9a6d35d5035cf9244b28 100644 (file)
@@ -6,7 +6,7 @@ config BR2_COMPILE_UTIL_LINUX
        depends BR2_PACKAGE_FDISK || BR2_PACKAGE_SWAP_UTILS
 
 config BR2_PACKAGE_FDISK
        depends BR2_PACKAGE_FDISK || BR2_PACKAGE_SWAP_UTILS
 
 config BR2_PACKAGE_FDISK
-       prompt "fdisk............................. A partition table manipulation utility"
+       prompt "fdisk............................. Partition table manipulation utility"
        tristate
        default m if CONFIG_DEVEL
        select BR2_COMPILE_UTIL_LINUX
        tristate
        default m if CONFIG_DEVEL
        select BR2_COMPILE_UTIL_LINUX
@@ -15,6 +15,17 @@ config BR2_PACKAGE_FDISK
          
          http://www.kernel.org/pub/linux/utils/util-linux/
 
          
          http://www.kernel.org/pub/linux/utils/util-linux/
 
+config BR2_PACKAGE_LOSETUP
+       prompt "losetup........................... Loop devices setup and control utility"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_COMPILE_UTIL_LINUX
+       select BR2_PACKAGE_KMOD_LOOP
+       help
+         A loop devices setup and control utility
+         
+         http://www.kernel.org/pub/linux/utils/util-linux/
+
 config BR2_PACKAGE_SWAP_UTILS
        prompt "swap-utils........................ Swap space management utilities"
        tristate
 config BR2_PACKAGE_SWAP_UTILS
        prompt "swap-utils........................ Swap space management utilities"
        tristate
index ad5dd19dbacdb19e4473db997e58efc0ac5cfdf0..7eb180173e2d1e5a36584af1a3542be4840b31a5 100644 (file)
@@ -19,6 +19,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LOSETUP,losetup,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,SWAP_UTILS,swap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
 $(eval $(call PKG_template,SWAP_UTILS,swap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
@@ -47,6 +48,12 @@ $(IPKG_FDISK):
        $(RSTRIP) $(IDIR_FDISK)
        $(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
 
        $(RSTRIP) $(IDIR_FDISK)
        $(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
 
+$(IPKG_LOSETUP):
+       install -d -m0755 $(IDIR_LOSETUP)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/losetup $(IDIR_LOSETUP)/usr/sbin/
+       $(RSTRIP) $(IDIR_LOSETUP)
+       $(IPKG_BUILD) $(IDIR_LOSETUP) $(PACKAGE_DIR)
+
 $(IPKG_SWAP_UTILS):
        install -d -m0755 $(IDIR_SWAP_UTILS)/usr/sbin
        cp -fpR $(PKG_INSTALL_DIR)/sbin/mkswap $(IDIR_SWAP_UTILS)/usr/sbin/
 $(IPKG_SWAP_UTILS):
        install -d -m0755 $(IDIR_SWAP_UTILS)/usr/sbin
        cp -fpR $(PKG_INSTALL_DIR)/sbin/mkswap $(IDIR_SWAP_UTILS)/usr/sbin/
index e34c91cbd45a8730ac7172a891dbdb96a4c9440b..cf73e98df3e1cdbc3b900f7da56f943f2798a203 100644 (file)
@@ -2,4 +2,4 @@ Package: fdisk
 Priority: optional
 Section: admin
 Depends:
 Priority: optional
 Section: admin
 Depends:
-Description: A partition table manipulation utility
+Description: Partition table manipulation utility
diff --git a/openwrt/package/util-linux/ipkg/losetup.control b/openwrt/package/util-linux/ipkg/losetup.control
new file mode 100644 (file)
index 0000000..5023050
--- /dev/null
@@ -0,0 +1,5 @@
+Package: losetup
+Priority: optional
+Section: admin
+Depends: kmod-loop
+Description: Loop devices setup and control utility