[packages] ruby: add /usr/bin/gem binary to ruby-gems (closes: #7358)
authorNicolas Thill <nico@openwrt.org>
Mon, 24 May 2010 17:33:10 +0000 (17:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 24 May 2010 17:33:10 +0000 (17:33 +0000)
SVN-Revision: 21565

lang/ruby/Makefile

index ec0d9d9f3c4a653d3ade8a7bed76191e06c0ca8d..6829fe84e7e1a89fa5e07f7857e624414992b755 100644 (file)
@@ -17,7 +17,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=ruby
 PKG_LIBVER:=1.9.1
 PKG_VERSION:=$(PKG_LIBVER)-p376
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=ftp://ftp.ruby-lang.org/pub/ruby/1.9/
@@ -334,6 +334,8 @@ define Package/ruby-gdbm/install
 endef
 
 define Package/ruby-gems/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(CP) $(PKG_INSTALL_DIR)/usr/bin/gem $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/lib/ruby/$(PKG_LIBVER)
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ruby/$(PKG_LIBVER)/rubygems.rb $(1)/usr/lib/ruby/$(PKG_LIBVER)/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/ruby/$(PKG_LIBVER)/rubygems $(1)/usr/lib/ruby/$(PKG_LIBVER)/