adds option to select tls provider when using wpa_supplicant, fixes #3770
authorJohn Crispin <john@openwrt.org>
Wed, 30 Jul 2008 17:04:50 +0000 (17:04 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 30 Jul 2008 17:04:50 +0000 (17:04 +0000)
SVN-Revision: 12016

package/wpa_supplicant/Config.in
package/wpa_supplicant/Makefile

index d3700fae840c9d0e228060ee93dd1a4dc4a3fa7d..10b8a43a874509477bf2dadb298850fd5459279b 100644 (file)
@@ -6,4 +6,16 @@ config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
        help
          This disables the timestamp check for certificates in wpa_supplicant
          Useful for devices without RTC that cannot reliably get the real date/time
+choice
+        prompt "Choose TLS provider"
+        default WPA_SUPPLICANT_INTERNAL
+       depends PACKAGE_wpa-supplicant
+
+config WPA_SUPPLICANT_INTERNAL
+       bool "internal"
+
+config WPA_SUPPLICANT_OPENSSL
+       bool "openssl"
+       select PACKAGE_libopenssl
 
+endchoice
index d6ff186cc5d46e0a1ee254551401f5868c97ad6c..d57e3cd2f012b51badae2e3efae69ed33fcaee11 100644 (file)
@@ -23,6 +23,7 @@ define Package/wpa-supplicant
   SECTION:=net
   CATEGORY:=Network
   TITLE:=WPA Supplicant
+  DEPENDS:=$(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),+libopenssl)
   URL:=http://hostap.epitest.fi/wpa_supplicant/
 endef
 
@@ -52,6 +53,7 @@ TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/madwifi $(if $(CONFIG_WPA_SUPPLICA
 define Build/Configure
        cp $(CONFIG) $(PKG_BUILD_DIR)/wpa_supplicant/.config
        $(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
+       $(if $(CONFIG_WPA_SUPPLICANT_OPENSSL),$(SED) 's|^CONFIG_TLS.*|CONFIG_TLS=openssl|g' $(PKG_BUILD_DIR)/wpa_supplicant/.config)
 endef
 
 define Build/Compile