[packages] SDL_sound: use PKG_INSTALL, disable all external libs use explicitely...
authorNicolas Thill <nico@openwrt.org>
Tue, 9 Mar 2010 19:11:53 +0000 (19:11 +0000)
committerNicolas Thill <nico@openwrt.org>
Tue, 9 Mar 2010 19:11:53 +0000 (19:11 +0000)
SVN-Revision: 20102

libs/libsdl_sound/Makefile

index 2d1953758d57938c4ad3fcac07d056e488a31b2d..52587ae29e81d9b2b0e3779904d40c3a39674363 100644 (file)
@@ -9,12 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libsdl-sound
 PKG_VERSION:=1.0.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=SDL_sound-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://icculus.org/SDL_sound/downloads/
 PKG_MD5SUM:=aa09cd52df85d29bee87a664424c94b5
+
 PKG_BUILD_DIR:=$(BUILD_DIR)/SDL_sound-$(PKG_VERSION)
+PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -31,20 +33,14 @@ define Package/libsdl-sound/description
   of several popular sound file formats, such as .WAV and .MP3.
 endef
 
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
-
 CONFIGURE_ARGS += \
-       --with-sdl-exec-prefix=$(STAGING_DIR)
-
-CONFIGURE_VARS += \
-       LIBS="-lSDL -ldirect -ldirectfb -lfusion"
-
-define Build/Compile
-       rm -rf $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR) \
-               DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install
-endef
+       --with-sdl-prefix="$(STAGING_DIR)/usr" \
+       --disable-flac \
+       --disable-mikmod \
+       --disable-modplug \
+       --disable-ogg \
+       --disable-smpeg \
+       --disable-speex \
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
@@ -58,7 +54,7 @@ endef
 
 define Package/libsdl-sound/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libSDL_sound*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libSDL_sound*.so.* $(1)/usr/lib/
 endef
 
 $(eval $(call BuildPackage,libsdl-sound))