python: refresh patches
authorMichael Büsch <mb@bu3sch.de>
Tue, 7 Sep 2010 11:16:04 +0000 (11:16 +0000)
committerMichael Büsch <mb@bu3sch.de>
Tue, 7 Sep 2010 11:16:04 +0000 (11:16 +0000)
SVN-Revision: 22968

lang/python/patches/000-cross-compile.patch
lang/python/patches/010-cannot-run-test-programm.patch
lang/python/patches/020-dont-compile-python-files.patch
lang/python/patches/030-fixup-include-dirs.patch
lang/python/patches/040-dont-import-cross-compiled-modules.patch
lang/python/patches/070-dont-clean-ipkg-install.patch
lang/python/patches/080-distutils-dont_adjust_files.patch
lang/python/patches/090-fix-ctypes.patch
lang/python/patches/110-enable-zlib.patch
lang/python/patches/120-force-internal-modules-for-hashlib.patch

index 4cbab182ffd88e6d99fc0a9d0b383fdd9d2cb556..dc2e1669777c426fd747a7ca8fa6c801b96f6db8 100644 (file)
@@ -1,16 +1,18 @@
-Index: Python-2.5.1/Makefile.pre.in
-===================================================================
---- Python-2.5.1.orig/Makefile.pre.in  2007-07-30 12:55:24.000000000 -0500
-+++ Python-2.5.1/Makefile.pre.in       2007-07-30 12:55:24.000000000 -0500
-@@ -175,6 +175,7 @@
+---
+ Makefile.pre.in |   25 +++++++++++++------------
+ 1 file changed, 13 insertions(+), 12 deletions(-)
+
+--- Python-2.6.4.orig/Makefile.pre.in
++++ Python-2.6.4/Makefile.pre.in
+@@ -175,6 +175,7 @@ UNICODE_OBJS=   @UNICODE_OBJS@
  
  PYTHON=               python$(EXE)
  BUILDPYTHON=  python$(BUILDEXE)
 +HOSTPYTHON=   $(BUILDPYTHON)
  
- # === Definitions added by makesetup ===
-@@ -205,7 +206,7 @@
+ # The task to run while instrument when building the profile-opt target
+ PROFILE_TASK= $(srcdir)/Tools/pybench/pybench.py -n 2 --with-gc --with-syscheck
+@@ -205,7 +206,7 @@ GRAMMAR_INPUT=     $(srcdir)/Grammar/Grammar
  ##########################################################################
  # Parser
  PGEN=         Parser/pgen$(EXE)
@@ -19,7 +21,23 @@ Index: Python-2.5.1/Makefile.pre.in
  POBJS=                \
                Parser/acceler.o \
                Parser/grammar1.o \
-@@ -394,8 +395,8 @@
+@@ -370,7 +371,7 @@ build_all_generate_profile:
+       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
+ run_profile_task:
+-      ./$(BUILDPYTHON) $(PROFILE_TASK)
++      $(HOSTPYTHON) $(PROFILE_TASK)
+ build_all_use_profile:
+       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
+@@ -388,14 +389,14 @@ $(BUILDPYTHON):  Modules/python.o $(LIBRA
+                       $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
+ platform: $(BUILDPYTHON)
+-      $(RUNSHARED) ./$(BUILDPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
++      $(RUNSHARED) $(HOSTPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
  # Build the shared modules
  sharedmods: $(BUILDPYTHON)
        @case $$MAKEFLAGS in \
@@ -27,20 +45,28 @@ Index: Python-2.5.1/Makefile.pre.in
 -      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' ./$(BUILDPYTHON) -E $(srcdir)/setup.py build;; \
 +      *s*) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py -q build;; \
 +      *) $(RUNSHARED) CC='$(CC)' LDSHARED='$(BLDSHARED)' OPT='$(OPT)' $(HOSTPYTHON) -E $(srcdir)/setup.py build;; \
-       esac
+       esac
  
  # Build static library
-@@ -512,8 +513,8 @@
+@@ -517,7 +518,7 @@ Modules/python.o: $(srcdir)/Modules/pyth
  
  $(GRAMMAR_H) $(GRAMMAR_C): $(PGEN) $(GRAMMAR_INPUT)
-               -@$(INSTALL) -d Include
+               -@$(INSTALL) -d Include
 -              -$(PGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
 +              -$(HOSTPGEN) $(GRAMMAR_INPUT) $(GRAMMAR_H) $(GRAMMAR_C)
  
  $(PGEN):      $(PGENOBJS)
                $(CC) $(OPT) $(LDFLAGS) $(PGENOBJS) $(LIBS) -o $(PGEN)
-@@ -993,7 +994,7 @@
+@@ -676,7 +677,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/pytho
+ TESTOPTS=     -l $(EXTRATESTOPTS)
+ TESTPROG=     $(srcdir)/Lib/test/regrtest.py
+-TESTPYTHON=   $(RUNSHARED) ./$(BUILDPYTHON) -E -tt
++TESTPYTHON=   $(RUNSHARED) $(HOSTPYTHON) -E -tt
+ test:         all platform
+               -find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
+               -$(TESTPYTHON) $(TESTPROG) $(TESTOPTS)
+@@ -1001,7 +1002,7 @@ libainstall:     all
  # Install the dynamically loadable modules
  # This goes into $(exec_prefix)
  sharedinstall:
@@ -49,38 +75,7 @@ Index: Python-2.5.1/Makefile.pre.in
                --prefix=$(prefix) \
                --install-scripts=$(BINDIR) \
                --install-platlib=$(DESTSHARED) \
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index c2ce5c6..63dc91e 100644
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -371,7 +371,7 @@ build_all_generate_profile:
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-generate" LIBS="$(LIBS) -lgcov"
- run_profile_task:
--      ./$(BUILDPYTHON) $(PROFILE_TASK)
-+      $(HOSTPYTHON) $(PROFILE_TASK)
- build_all_use_profile:
-       $(MAKE) all CFLAGS="$(CFLAGS) -fprofile-use"
-@@ -389,7 +389,7 @@ $(BUILDPYTHON):    Modules/python.o $(LIBRARY) $(LDLIBRARY)
-                       $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
- platform: $(BUILDPYTHON)
--      $(RUNSHARED) ./$(BUILDPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
-+      $(RUNSHARED) $(HOSTPYTHON) -E -c 'import sys ; from distutils.util import get_platform ; print get_platform()+"-"+sys.version[0:3]' >platform
- # Build the shared modules
-@@ -669,7 +669,7 @@ $(LIBRARY_OBJS) $(MODOBJS) Modules/python.o: $(PYTHON_HEADERS)
- TESTOPTS=     -l $(EXTRATESTOPTS)
- TESTPROG=     $(srcdir)/Lib/test/regrtest.py
--TESTPYTHON=   $(RUNSHARED) ./$(BUILDPYTHON) -E -tt
-+TESTPYTHON=   $(RUNSHARED) $(HOSTPYTHON) -E -tt
- test:         all platform
-               -find $(srcdir)/Lib -name '*.py[co]' -print | xargs rm -f
-@@ -1032,7 +1014,7 @@ frameworkinstallstructure:       $(LDLIBRARY)
+@@ -1039,7 +1040,7 @@ frameworkinstallstructure:       $(LDLIBRARY)
                fi; \
        done
        $(LN) -fsn include/python$(VERSION) $(DESTDIR)$(prefix)/Headers
@@ -89,7 +84,7 @@ index c2ce5c6..63dc91e 100644
        $(LN) -fsn $(VERSION) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Versions/Current
        $(LN) -fsn Versions/Current/$(PYTHONFRAMEWORK) $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/$(PYTHONFRAMEWORK)
        $(LN) -fsn Versions/Current/Headers $(DESTDIR)$(PYTHONFRAMEWORKINSTALLDIR)/Headers
-@@ -1074,7 +1056,7 @@ frameworkinstallextras:
+@@ -1081,7 +1082,7 @@ frameworkinstallextras:
  # This installs a few of the useful scripts in Tools/scripts
  scriptsinstall:
        SRCDIR=$(srcdir) $(RUNSHARED) \
@@ -98,7 +93,7 @@ index c2ce5c6..63dc91e 100644
        --prefix=$(prefix) \
        --install-scripts=$(BINDIR) \
        --root=/$(DESTDIR)
-@@ -1096,7 +1078,7 @@ config.status:   $(srcdir)/configure
+@@ -1103,7 +1104,7 @@ config.status:   $(srcdir)/configure
  
  # Run reindent on the library
  reindent:
@@ -107,7 +102,7 @@ index c2ce5c6..63dc91e 100644
  
  # Rerun configure with the same options as it was run last time,
  # provided the config.status script exists
-@@ -1192,7 +1174,7 @@ funny:
+@@ -1200,7 +1201,7 @@ funny:
  
  # Perform some verification checks on any modified files.
  patchcheck:
index 39da9dfdcf9de6075161c5c635039d5fae3fe32f..471f0089482c551028086c410a4b8aded585e2a6 100644 (file)
@@ -1,8 +1,10 @@
-diff --git a/configure.in b/configure.in
-index 14095a1..e7ab47f 100644
---- a/configure.in
-+++ b/configure.in
-@@ -2559,6 +2559,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_TRUE],
+---
+ configure.in |   46 ++++++++++++++++++++++++++++++++++------------
+ 1 file changed, 34 insertions(+), 12 deletions(-)
+
+--- Python-2.6.4.orig/configure.in
++++ Python-2.6.4/configure.in
+@@ -2653,6 +2653,7 @@ AC_CHECK_LIB(c, inet_aton, [$ac_cv_prog_
  # On Tru64, chflags seems to be present, but calling it will
  # exit Python
  AC_MSG_CHECKING(for chflags)
@@ -10,7 +12,7 @@ index 14095a1..e7ab47f 100644
  AC_TRY_RUN([
  #include <sys/stat.h>
  #include <unistd.h>
-@@ -2568,12 +2569,19 @@ int main(int argc, char*argv[])
+@@ -2662,12 +2663,19 @@ int main(int argc, char*argv[])
      return 1;
    return 0;
  }
@@ -34,7 +36,7 @@ index 14095a1..e7ab47f 100644
  AC_TRY_RUN([
  #include <sys/stat.h>
  #include <unistd.h>
-@@ -2583,10 +2591,16 @@ int main(int argc, char*argv[])
+@@ -2677,10 +2685,16 @@ int main(int argc, char*argv[])
      return 1;
    return 0;
  }
@@ -55,7 +57,7 @@ index 14095a1..e7ab47f 100644
  
  dnl Check if system zlib has *Copy() functions
  dnl
-@@ -3664,6 +3664,7 @@ else
+@@ -3781,6 +3795,7 @@ else
  fi
  
  AC_MSG_CHECKING(for %zd printf() format support)
@@ -63,7 +65,7 @@ index 14095a1..e7ab47f 100644
  AC_TRY_RUN([#include <stdio.h>
  #include <stddef.h>
  #include <string.h>
-@@ -3697,10 +3698,17 @@ int main()
+@@ -3814,10 +3829,17 @@ int main()
        return 1;
  
      return 0;
index 224d466eb93b0f8852eed610f132ba19173ad429..b3dd89d5e2314bbf394567a292d586dd9c3f7c7a 100644 (file)
@@ -1,8 +1,10 @@
-diff --git a/Makefile.pre.in b/Makefile.pre.in
-index a341e63..e949653 100644
---- a/Makefile.pre.in
-+++ b/Makefile.pre.in
-@@ -879,22 +879,6 @@ libinstall:       build_all $(srcdir)/Lib/$(PLATDIR)
+---
+ Makefile.pre.in |   16 ----------------
+ 1 file changed, 16 deletions(-)
+
+--- Python-2.6.4.orig/Makefile.pre.in
++++ Python-2.6.4/Makefile.pre.in
+@@ -887,22 +887,6 @@ libinstall:       build_all $(srcdir)/Lib/$(PL
                done; \
        done
        $(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
index eba4d2563e9e3b32bf3f8973f2cef1478d70b411..ad009562e516bf84e8b8ece0c6ccc2bea04269dd 100644 (file)
@@ -1,7 +1,9 @@
-diff --git a/setup.py b/setup.py
-index 32e1af8..f7f190f 100644
---- a/setup.py
-+++ b/setup.py
+---
+ setup.py |   15 ++-------------
+ 1 file changed, 2 insertions(+), 13 deletions(-)
+
+--- Python-2.6.4.orig/setup.py
++++ Python-2.6.4/setup.py
 @@ -309,9 +309,6 @@ class PyBuildExt(build_ext):
          return sys.platform
  
index 8d96020c53b22939c6d927f9cb0f98dd77f9196d..85e1e7e8aa0b496c7eb05ecb892be424506743ef 100644 (file)
@@ -1,7 +1,9 @@
-diff --git a/setup.py b/setup.py
-index f7f190f..6ca7a1d 100644
---- a/setup.py
-+++ b/setup.py
+---
+ setup.py |   30 ------------------------------
+ 1 file changed, 30 deletions(-)
+
+--- Python-2.6.4.orig/setup.py
++++ Python-2.6.4/setup.py
 @@ -270,36 +270,6 @@ class PyBuildExt(build_ext):
          ext_filename = os.path.join(
              self.build_lib,
@@ -36,6 +38,6 @@ index f7f190f..6ca7a1d 100644
 -                          'failed with %s: %s' % (ext.name, exc_type, why),
 -                          level=3)
 -            self.failed.append(ext.name)
-
-    def get_platform(self):
  
+     def get_platform(self):
+         # Get value of sys.platform
index 0eb04bb6ebd81b02f2379725d0ea70ccc1da7da7..0eee56bb9b20aff019e2ab2f2b876710177c35a7 100644 (file)
@@ -1,8 +1,12 @@
---- Python-2.5.1/Makefile.pre.in.orig  2008-10-02 12:30:28.000000000 +0200
-+++ Python-2.5.1/Makefile.pre.in       2008-10-02 12:31:50.000000000 +0200
-@@ -996,11 +996,11 @@
+---
+ Makefile.pre.in |    6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+--- Python-2.6.4.orig/Makefile.pre.in
++++ Python-2.6.4/Makefile.pre.in
+@@ -1118,11 +1118,11 @@ TAGS::
  # Sanitation targets -- clean leaves libraries, executables and tags
- # files, which clobber removes those as well
+ # files, which clobber removes as well
  pycremoval:
 -      find $(srcdir) -name '*.py[co]' -exec rm -f {} ';'
 +      find $(srcdir) ! -path './ipkg-install/*' -name '*.py[co]' -exec rm -f {} ';'
@@ -14,4 +18,4 @@
 +      find . ! -path './ipkg-install/*' -name '*.s[ol]' -exec rm -f {} ';'
        find $(srcdir)/build -name 'fficonfig.h' -exec rm -f {} ';' || true
        find $(srcdir)/build -name 'fficonfig.py' -exec rm -f {} ';' || true
+       -rm -f Lib/lib2to3/*Grammar*.pickle
index 1d086c18f50d6886db45e5f4aba945bd185f8feb..c4798e50bf65897390a123c61462466b0d4a16a6 100644 (file)
@@ -1,8 +1,10 @@
-Index: build_scripts.py
-===================================================================
---- a/Lib/distutils/command/build_scripts.py
-+++ b/Lib/distutils/command/build_scripts.py
-@@ -52,10 +52,7 @@
+---
+ Lib/distutils/command/build_scripts.py |   43 +++------------------------------
+ 1 file changed, 4 insertions(+), 39 deletions(-)
+
+--- Python-2.6.4.orig/Lib/distutils/command/build_scripts.py
++++ Python-2.6.4/Lib/distutils/command/build_scripts.py
+@@ -54,10 +54,7 @@ class build_scripts (Command):
  
  
      def copy_scripts (self):
@@ -14,7 +16,7 @@ Index: build_scripts.py
          """
          self.mkpath(self.build_dir)
          outfiles = []
-@@ -78,41 +75,9 @@
+@@ -80,41 +77,9 @@ class build_scripts (Command):
                  if not self.dry_run:
                      raise
                  f = None
index 67a8a3eecdcd3db23fde033b1a67a70bab6a9ec4..616e76d46b15cef45e33b5e5dd8d2878044d7117 100644 (file)
@@ -1,8 +1,10 @@
-Index: Lib/ctypes/__init__.py
-===================================================================
---- a/Lib/ctypes/__init__.py   (revision 77004)
-+++ b/Lib/ctypes/__init__.py   (working copy)
-@@ -538,9 +538,3 @@
+---
+ Lib/ctypes/__init__.py |    6 ------
+ 1 file changed, 6 deletions(-)
+
+--- Python-2.6.4.orig/Lib/ctypes/__init__.py
++++ Python-2.6.4/Lib/ctypes/__init__.py
+@@ -538,9 +538,3 @@ for kind in [c_ushort, c_uint, c_ulong,
      elif sizeof(kind) == 4: c_uint32 = kind
      elif sizeof(kind) == 8: c_uint64 = kind
  del(kind)
index c42597bea4d5d9ef8a192e38bf6d64b3bf51b2de..ac2e05147f63d50c89a13b014b3de761d9e298ad 100644 (file)
@@ -1,6 +1,10 @@
---- Python-2.6.4/Modules/Setup.dist    2008-11-27 11:15:12.000000000 +0100
-+++ Python-2.6.4/Modules/Setup.dist    2010-02-27 04:14:15.000000000 +0100
-@@ -460,7 +460,7 @@
+---
+ Modules/Setup.dist |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- Python-2.6.4.orig/Modules/Setup.dist
++++ Python-2.6.4/Modules/Setup.dist
+@@ -460,7 +460,7 @@ GLHACK=-Dclear=__GLclear
  # Andrew Kuchling's zlib module.
  # This require zlib 1.1.3 (or later).
  # See http://www.gzip.org/zlib/
index eae7de821620ce1c11ff9a7e07ab6714db4baa5a..f0bdeef0c9b57db790a090d85894159ea0ec8432 100644 (file)
@@ -1,7 +1,9 @@
-diff --git a/setup.py b/setup.py
-index 0e08e74..65161db 100644
---- a/setup.py
-+++ b/setup.py
+---
+ setup.py |   10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+--- Python-2.6.4.orig/setup.py
++++ Python-2.6.4/setup.py
 @@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
  
          #print 'openssl_ver = 0x%08x' % openssl_ver