icecast: fix build, properly use libvorbisidec
authorFelix Fietkau <nbd@openwrt.org>
Wed, 2 Feb 2011 02:36:56 +0000 (02:36 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 2 Feb 2011 02:36:56 +0000 (02:36 +0000)
SVN-Revision: 25306

net/icecast/Makefile
net/icecast/patches/002-curl_config.patch [deleted file]
net/icecast/patches/010-fix_libcurl_test_crap.patch [new file with mode: 0644]

index 6d47962047d55754abe925b2cc9896af1dc49d7a..2aad28bc9166b050f229dfc9484a5be52436e356 100644 (file)
@@ -53,12 +53,12 @@ define Build/Configure
                BUILD_DIR="$(PKG_BUILD_DIR)" \
                V=99 \
                compile
-       $(SED) 's,-lvorbisidec,$(TREMOR_DIR)/lib/libvorbisidec.a,g' $(PKG_BUILD_DIR)/configure
+       $(SED) 's,-lvorbis ,$(TREMOR_DIR)/lib/libvorbisidec.a -logg ,g' $(PKG_BUILD_DIR)/configure
        $(call Build/Configure/Default, \
                --enable-yp \
                --with-curl="yes" \
                --with-curl-config="$(STAGING_DIR)/usr/bin/curl-config" \
-               --with-ogg="$(TREMOR_DIR)" \
+               --with-ogg="$(STAGING_DIR)/usr" \
                --with-speex="no" \
                --with-theora="no" \
                --with-vorbis="$(TREMOR_DIR)" \
diff --git a/net/icecast/patches/002-curl_config.patch b/net/icecast/patches/002-curl_config.patch
deleted file mode 100644 (file)
index c193aa9..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- icecast-2.3.2/configure    2008-09-29 20:11:37.000000000 +0200
-+++ icecast-2.3.2.new/configure        2008-09-29 20:12:00.000000000 +0200
-@@ -24198,8 +24198,7 @@
-   { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
- See \`config.log' for more details." >&5
- echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
--   { (exit 1); exit 1; }; }
-+See \`config.log' for more details." >&2;} }
- else
-   cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h.  */
diff --git a/net/icecast/patches/010-fix_libcurl_test_crap.patch b/net/icecast/patches/010-fix_libcurl_test_crap.patch
new file mode 100644 (file)
index 0000000..15bb534
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/m4/xiph_curl.m4
++++ b/m4/xiph_curl.m4
+@@ -52,7 +52,7 @@
+ AC_MSG_CHECKING(for libcurl)
+ if test "$curl_ok" = "yes"
+ then
+-    AC_RUN_IFELSE(AC_LANG_SOURCE([
++    AC_COMPILE_IFELSE(AC_LANG_SOURCE([
+ #include <curl/curl.h>
+ int main()
+ {