kernel: remove wrong chunks from the 2.6.37 and 2.6.38 version of the mips oprofile fix
authorFelix Fietkau <nbd@openwrt.org>
Fri, 25 Mar 2011 22:18:17 +0000 (22:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 25 Mar 2011 22:18:17 +0000 (22:18 +0000)
SVN-Revision: 26297

target/linux/generic/patches-2.6.37/208-mips_oprofile_fix.patch
target/linux/generic/patches-2.6.38/208-mips_oprofile_fix.patch

index 2841ed883e49bf016b6bf53bd12fb5acccb77121..f83c96bb81f64a65764dc81705927b24c3933353 100644 (file)
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
-   endif
- endif
-+ifndef CONFIG_PROFILING
-+  cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
-   ifndef KBUILD_MCOUNT_RA_ADDRESS
-     ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
 --- a/arch/mips/oprofile/op_model_mipsxx.c
 +++ b/arch/mips/oprofile/op_model_mipsxx.c
 @@ -298,6 +298,11 @@ static void reset_counters(void *arg)
 --- a/arch/mips/oprofile/op_model_mipsxx.c
 +++ b/arch/mips/oprofile/op_model_mipsxx.c
 @@ -298,6 +298,11 @@ static void reset_counters(void *arg)
index 2841ed883e49bf016b6bf53bd12fb5acccb77121..f83c96bb81f64a65764dc81705927b24c3933353 100644 (file)
@@ -1,15 +1,3 @@
---- a/arch/mips/Makefile
-+++ b/arch/mips/Makefile
-@@ -48,6 +48,9 @@ ifneq ($(SUBARCH),$(ARCH))
-   endif
- endif
-+ifndef CONFIG_PROFILING
-+  cflags-y := -ffunction-sections
-+endif
- ifdef CONFIG_FUNCTION_GRAPH_TRACER
-   ifndef KBUILD_MCOUNT_RA_ADDRESS
-     ifeq ($(call cc-option-yn,-mmcount-ra-address), y)
 --- a/arch/mips/oprofile/op_model_mipsxx.c
 +++ b/arch/mips/oprofile/op_model_mipsxx.c
 @@ -298,6 +298,11 @@ static void reset_counters(void *arg)
 --- a/arch/mips/oprofile/op_model_mipsxx.c
 +++ b/arch/mips/oprofile/op_model_mipsxx.c
 @@ -298,6 +298,11 @@ static void reset_counters(void *arg)