[packages] dbus-glib:
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Dec 2010 21:44:57 +0000 (21:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 8 Dec 2010 21:44:57 +0000 (21:44 +0000)
- remove private libtool copy
- patch out invocations of host commands
- provide missing macros
- disables tests, examples and docs

SVN-Revision: 24371

libs/dbus-glib/Makefile
libs/dbus-glib/patches/001-cross.patch
libs/dbus-glib/patches/002-missing-macros.patch [new file with mode: 0644]
libs/dbus-glib/patches/003-disable-tests-docs-examples.patch [new file with mode: 0644]

index 0ba177504aa188fe37740639078f16b28400654d..75d4b7d1f24cf63b30f45ffa9e62b2471f81f42b 100644 (file)
@@ -16,6 +16,8 @@ PKG_SOURCE_URL:=http://dbus.freedesktop.org/releases/dbus-glib/
 PKG_MD5SUM:=86ea60ba2118a1b9deafe8257f6a6a1a
 
 PKG_FIXUP:=libtool
+PKG_REMOVE_FILES:=aclocal.m4 ltmain.sh
+
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
index 89c97a4dc716cbd9cf3bcad5340570584682e6ab..486782ddf2144a3d5a2dd6e112912b7fdad03f1e 100644 (file)
@@ -1,9 +1,7 @@
-Index: dbus-glib-0.74/dbus/Makefile.in
-===================================================================
---- dbus-glib-0.74.orig/dbus/Makefile.in       2007-10-03 09:03:44.000000000 +0200
-+++ dbus-glib-0.74/dbus/Makefile.in    2007-10-03 09:03:45.000000000 +0200
-@@ -292,7 +292,7 @@
- target_vendor = @target_vendor@
+--- a/dbus/Makefile.in
++++ b/dbus/Makefile.in
+@@ -315,7 +315,7 @@ target_vendor = @target_vendor@
+ top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
 -SUBDIRS = . examples
@@ -11,16 +9,88 @@ Index: dbus-glib-0.74/dbus/Makefile.in
  INCLUDES = \
        -I$(top_srcdir)                                         \
        -I$(top_builddir)                                       \
-Index: dbus-glib-0.74/Makefile.in
-===================================================================
---- dbus-glib-0.74.orig/Makefile.in    2007-10-03 09:04:15.000000000 +0200
-+++ dbus-glib-0.74/Makefile.in 2007-10-03 09:04:26.000000000 +0200
-@@ -261,7 +261,7 @@
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -267,8 +267,8 @@ top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  GLIB_PC = dbus-glib-1.pc
 -SUBDIRS = dbus tools test doc
+-DIST_SUBDIRS = dbus tools test doc m4
 +SUBDIRS = dbus
- DIST_SUBDIRS = dbus tools test doc m4
++DIST_SUBDIRS = dbus tools m4
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = $(GLIB_PC)
+ DISTCLEANFILES = \
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -1,24 +1,10 @@
+ INCLUDES=-I$(top_srcdir) $(DBUS_CFLAGS) $(DBUS_GLIB_CFLAGS) $(DBUS_X_CFLAGS) $(DBUS_GTK_THREADS_CFLAGS) -DDBUS_COMPILATION
+-nodist_libdbus_glib_HEADERS = dbus-glib-bindings.h
+ libdbus_glibdir = $(includedir)/dbus-1.0/dbus
+-dbus-glib-bindings.h: dbus-bus-introspect.xml $(top_builddir)/dbus/dbus-binding-tool$(EXEEXT)
+-      $(top_builddir)/dbus/dbus-binding-tool --mode=glib-client --prefix=dbus_bus --output=dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+-BUILT_SOURCES = dbus-glib-bindings.h dbus-bus-introspect.xml
+-
+-if USE_INTROSPECT_XML
+-dbus-bus-introspect.xml: $(INTROSPECT_XML_PATH)
+-      cp $(INTROSPECT_XML_PATH) dbus-bus-introspect.xml
+-else
+-dbus-bus-introspect.xml:
+-      DBUS_TOP_BUILDDIR=$(top_builddir) @DBUS_DAEMONDIR@dbus-daemon --introspect > dbus-bus-introspect.xml.tmp && mv dbus-bus-introspect.xml.tmp dbus-bus-introspect.xml
+-endif
++BUILT_SOURCES = 
+ EXTRA_DIST = run-with-tmp-session-bus.sh session.conf
+ CLEANFILES =                          \
+-      run-with-tmp-session-bus.conf   \
+-        dbus-bus-introspect.xml         \
+-        dbus-glib-bindings.h
++      run-with-tmp-session-bus.conf
+--- a/configure.ac
++++ b/configure.ac
+@@ -58,9 +58,6 @@ AC_ARG_ENABLE(bash-completion, AS_HELP_S
+ AC_ARG_WITH(test-socket-dir, AS_HELP_STRING([--with-test-socket-dir=[dirname]],[Where to put sockets for make check]))
+-AC_ARG_WITH(introspect-xml, AS_HELP_STRING([--with-introspect-xml=[filename]],[Pass in a pregenerated dbus daemon introspection xml file (as generated by 'dbus-daemon --introspect') to use instead of querying the installed dbus daemon]))
+-
+-
+ AM_CONDITIONAL(DBUS_BASH_COMPLETION, test x$enable_bash_completion = xyes)
+ if test x$enable_bash_completion = xyes; then
+   AC_DEFINE(DBUS_BASH_COMPLETION,1,[Enable bash completion])
+@@ -815,18 +812,6 @@ fi
+ AC_SUBST(TEST_SOCKET_DIR)
+ AC_DEFINE_UNQUOTED(DBUS_TEST_SOCKET_DIR, "$TEST_SOCKET_DIR", [Where to put test sockets])
+-#### Test if we should generate daemon introspection xml
+-use_introspect_xml=false
+-
+-if ! test -z "$with_introspect_xml" ; then
+-  use_introspect_xml=true
+-  INTROSPECT_XML_PATH="$with_introspect_xml"
+-  AC_DEFINE(INTROSPECT_XML_PATH, "$INTROSPECT_XML_PATH", [Path to pregenerated xml for dbus daemon introspection])
+-  AC_SUBST(INTROSPECT_XML_PATH)
+-fi
+-
+-AM_CONDITIONAL(USE_INTROSPECT_XML, $use_introspect_xml)
+-
+ AC_OUTPUT([
+ Makefile
+ m4/Makefile
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,7 +1,7 @@
+ GLIB_PC=dbus-glib-1.pc
+-SUBDIRS=dbus tools test doc
+-DIST_SUBDIRS=dbus tools test doc m4
++SUBDIRS=dbus tools
++DIST_SUBDIRS=dbus tools m4
  pkgconfigdir = $(libdir)/pkgconfig
  pkgconfig_DATA = $(GLIB_PC)
diff --git a/libs/dbus-glib/patches/002-missing-macros.patch b/libs/dbus-glib/patches/002-missing-macros.patch
new file mode 100644 (file)
index 0000000..be3c4c6
--- /dev/null
@@ -0,0 +1,5 @@
+--- /dev/null
++++ b/acinclude.m4
+@@ -0,0 +1,2 @@
++dnl fake GTK doc check
++AC_DEFUN([GTK_DOC_CHECK],[AM_CONDITIONAL(ENABLE_GTK_DOC,false)])
diff --git a/libs/dbus-glib/patches/003-disable-tests-docs-examples.patch b/libs/dbus-glib/patches/003-disable-tests-docs-examples.patch
new file mode 100644 (file)
index 0000000..e6945d9
--- /dev/null
@@ -0,0 +1,29 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -815,18 +815,7 @@ AC_DEFINE_UNQUOTED(DBUS_TEST_SOCKET_DIR,
+ AC_OUTPUT([
+ Makefile
+ m4/Makefile
+-doc/Makefile
+-doc/reference/Makefile
+-doc/reference/version.xml
+ dbus/Makefile
+-dbus/examples/Makefile
+-dbus/examples/statemachine/Makefile
+-test/Makefile
+-test/core/Makefile
+-test/interfaces/Makefile
+-test/data/valid-service-files/debug-glib.service
+-test/data/valid-service-files/debug-echo.service
+-test/data/valid-service-files/interfaces-test.service
+ tools/Makefile
+ dbus-glib-1.pc
+ dbus-glib-1-uninstalled.pc
+--- a/dbus/Makefile.am
++++ b/dbus/Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = . examples
++SUBDIRS = .
+ INCLUDES = \
+       -I$(top_srcdir)                                         \