mpd will now let alsa be enabled if the soundcore kmod is present
authorJohn Crispin <john@openwrt.org>
Sun, 29 Jul 2007 19:30:39 +0000 (19:30 +0000)
committerJohn Crispin <john@openwrt.org>
Sun, 29 Jul 2007 19:30:39 +0000 (19:30 +0000)
SVN-Revision: 8221

sound/mpd/Makefile

index 6dee11874c16ecfefa56bc6147c156f256bc1c04..51b716fe8acd49e018bb896e0e6fa91401d167c9 100644 (file)
@@ -38,9 +38,13 @@ define Package/mpd/conffiles
 /etc/mpd.conf
 endef
 
+ifndef CONFIG_PACKAGE_kmod-soundcore
+       EXTRA_CONFIG_PARAM:=--disable-alsa
+endif
+
 define Build/Configure
        $(call Build/Configure/Default, \
-               --disable-alsa \
+               $(EXTRA_CONFIG_PARAM) \
                --disable-shout \
                --disable-mod \
                --disable-audiofile \