[packages] minidlna: Version bump Minidlna 1.0.19
authorVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 7 Apr 2011 23:23:32 +0000 (23:23 +0000)
committerVasilis Tsiligiannis <acinonyx@openwrt.gr>
Thu, 7 Apr 2011 23:23:32 +0000 (23:23 +0000)
Version bump minidlna to 1.0.19. I didn't find an official changelog. Reading a diff looks like a change in license from GPL v2 or later to strict GPL v2, as well as bug fixes and translation updates. It's streaming as expected. Two patches were rebased.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
SVN-Revision: 26526

multimedia/minidlna/Makefile
multimedia/minidlna/patches/001-genconfig-checks.patch
multimedia/minidlna/patches/002-makefile-tweaks.patch
multimedia/minidlna/patches/010-genconfig-checks.patch [new file with mode: 0644]
multimedia/minidlna/patches/020-makefile-tweaks.patch [new file with mode: 0644]

index e28f431d6a0dbca5f52b4eddce3d4566f062b777..124ee21d349eb76c704fecee45d75f2752a8c910 100644 (file)
@@ -8,13 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=minidlna
-PKG_VERSION:=1.0.18
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.19
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_src.tar.gz
 PKG_SOURCE_URL:=@SF/minidlna
-PKG_MD5SUM:=8681b100242f0a2fef93cab7cdef061e
-PKG_BUILD_DIR:=$(BUILD_DIR)/minidlna
+PKG_MD5SUM:=8bb5f2c0abc009e16039d7deecf09cf6
 
 PKG_BUILD_PARALLEL:=0
 
index 58233eaca8b8110e4c5f36f6669190dccc225d79..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,41 +0,0 @@
---- a/genconfig.sh
-+++ b/genconfig.sh
-@@ -24,22 +24,22 @@
- # Detect if there are missing headers
- # NOTE: This check only works with a normal distro
--[ ! -e "/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
--[ ! -e "/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
--[ ! -e "/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
--[ ! -e "/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
--[ ! -e "/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
--[ ! -e "/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
--[ ! -e "/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
--[ ! -e "/usr/include/ffmpeg/avutil.h" -a \
--  ! -e "/usr/include/libavutil/avutil.h" -a \
--  ! -e "/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
--[ ! -e "/usr/include/ffmpeg/avformat.h" -a \
--  ! -e "/usr/include/libavformat/avformat.h" -a \
--  ! -e "/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
--[ ! -e "/usr/include/ffmpeg/avcodec.h" -a \
--  ! -e "/usr/include/libavcodec/avcodec.h" -a \
--  ! -e "/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/ffmpeg/avutil.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/libavutil/avutil.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/ffmpeg/avformat.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/libavformat/avformat.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
-+[ ! -e "$STAGING_DIR/usr/include/ffmpeg/avcodec.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/libavcodec/avcodec.h" -a \
-+  ! -e "$STAGING_DIR/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
- if [ -n "$MISSING" ]; then
-       echo -e "\nERROR!  Cannot continue."
-       echo -e "The following required libraries are either missing, or are missing development headers:\n"
index f357c2d43b395ec81b6578f0f372b085361ec834..e69de29bb2d1d6434b8b29ae775ad8c2e48c5391 100644 (file)
@@ -1,45 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -13,9 +13,21 @@
- #CFLAGS = -Wall -O -D_GNU_SOURCE -g -DDEBUG
- #CFLAGS = -Wall -g -Os -D_GNU_SOURCE
- CFLAGS = -Wall -g -O3 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
--       -I/usr/include/ffmpeg \
--       -I/usr/include/libavutil -I/usr/include/libavcodec -I/usr/include/libavformat \
--       -I/usr/include/ffmpeg/libavutil -I/usr/include/ffmpeg/libavcodec -I/usr/include/ffmpeg/libavformat
-+       -I$(STAGING_DIR)/usr/include \
-+       -I$(STAGING_DIR)/usr/include/FLAC \
-+       -I$(STAGING_DIR)/usr/include/libavcodec \
-+       -I$(STAGING_DIR)/usr/include/libavformat \
-+       -I$(STAGING_DIR)/usr/include/libavutil \
-+       -I$(STAGING_DIR)/usr/include/libexif \
-+       -I$(STAGING_DIR)/usr/include/uuid \
-+       -I$(STAGING_DIR)/usr/include/vorbis \
-+       -I$(ICONV_PREFIX)/include \
-+       -I$(INTL_PREFIX)/include
-+LDFLAGS = -L$(STAGING_DIR)/usr/lib \
-+        -L$(ICONV_PREFIX)/lib \
-+        -L$(INTL_PREFIX)/lib \
-+        -Wl,-rpath=$(STAGING_DIR)/usr/lib \
-+        -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
- #STATIC_LINKING: LDFLAGS = -static
- CC = gcc
- RM = rm -f
-@@ -36,7 +48,7 @@ BASEOBJS = minidlna.o upnphttp.o upnpdes
- ALLOBJS = $(BASEOBJS) $(LNXOBJS)
--LIBS = -lpthread -lexif -ljpeg -lsqlite3 -lavformat -lid3tag -lFLAC -lvorbis
-+LIBS = -liconv -lpthread -lexif -ljpeg -lsqlite3 -lavformat -lid3tag -lFLAC -lvorbis -luuid
- #STATIC_LINKING: LIBS = -lvorbis -logg -lm -lsqlite3 -lpthread -lexif -ljpeg -lFLAC -lm -lid3tag -lz -lavformat -lavutil -lavcodec -lm
- TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
-@@ -58,7 +70,7 @@ install:     minidlna
-       $(INSTALL) -d $(ETCINSTALLDIR)
-       $(INSTALL) --mode=0644 minidlna.conf $(ETCINSTALLDIR)
--minidlna:     $(BASEOBJS) $(LNXOBJS) $(LIBS)
-+minidlna:     $(BASEOBJS) $(LNXOBJS)
-       @echo Linking $@
-       @$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BASEOBJS) $(LNXOBJS) $(LIBS)
diff --git a/multimedia/minidlna/patches/010-genconfig-checks.patch b/multimedia/minidlna/patches/010-genconfig-checks.patch
new file mode 100644 (file)
index 0000000..b3dd305
--- /dev/null
@@ -0,0 +1,41 @@
+--- a/genconfig.sh
++++ b/genconfig.sh
+@@ -41,22 +41,22 @@ ${RM} ${CONFIGFILE}
+ # Detect if there are missing headers
+ # NOTE: This check only works with a normal distro
+-[ ! -e "/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
+-[ ! -e "/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
+-[ ! -e "/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
+-[ ! -e "/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
+-[ ! -e "/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
+-[ ! -e "/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
+-[ ! -e "/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
+-[ ! -e "/usr/include/ffmpeg/avutil.h" -a \
+-  ! -e "/usr/include/libavutil/avutil.h" -a \
+-  ! -e "/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
+-[ ! -e "/usr/include/ffmpeg/avformat.h" -a \
+-  ! -e "/usr/include/libavformat/avformat.h" -a \
+-  ! -e "/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
+-[ ! -e "/usr/include/ffmpeg/avcodec.h" -a \
+-  ! -e "/usr/include/libavcodec/avcodec.h" -a \
+-  ! -e "/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/sqlite3.h" ] && MISSING="libsqlite3 $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/jpeglib.h" ] && MISSING="libjpeg $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/libexif/exif-loader.h" ] && MISSING="libexif $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/id3tag.h" ] && MISSING="libid3tag $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/ogg/ogg.h" ] && MISSING="libogg $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/vorbis/codec.h" ] && MISSING="libvorbis $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/FLAC/metadata.h" ] && MISSING="libflac $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/ffmpeg/avutil.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/libavutil/avutil.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/ffmpeg/libavutil/avutil.h" ] && MISSING="libavutil $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/ffmpeg/avformat.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/libavformat/avformat.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/ffmpeg/libavformat/avformat.h" ] && MISSING="libavformat $MISSING"
++[ ! -e "${STAGING_DIR}/usr/include/ffmpeg/avcodec.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/libavcodec/avcodec.h" -a \
++  ! -e "${STAGING_DIR}/usr/include/ffmpeg/libavcodec/avcodec.h" ] && MISSING="libavcodec $MISSING"
+ if [ -n "$MISSING" ]; then
+       echo -e "\nERROR!  Cannot continue."
+       echo -e "The following required libraries are either missing, or are missing development headers:\n"
diff --git a/multimedia/minidlna/patches/020-makefile-tweaks.patch b/multimedia/minidlna/patches/020-makefile-tweaks.patch
new file mode 100644 (file)
index 0000000..18d901c
--- /dev/null
@@ -0,0 +1,46 @@
+--- a/Makefile
++++ b/Makefile
+@@ -13,9 +13,22 @@
+ #CFLAGS = -Wall -O -D_GNU_SOURCE -g -DDEBUG
+ #CFLAGS = -Wall -g -Os -D_GNU_SOURCE
+ CFLAGS = -Wall -g -O3 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 \
+-       -I/usr/include/ffmpeg \
+-       -I/usr/include/libavutil -I/usr/include/libavcodec -I/usr/include/libavformat \
+-       -I/usr/include/ffmpeg/libavutil -I/usr/include/ffmpeg/libavcodec -I/usr/include/ffmpeg/libavformat
++       -I$(STAGING_DIR)/usr/include \
++       -I$(STAGING_DIR)/usr/include/FLAC \
++       -I$(STAGING_DIR)/usr/include/libavcodec \
++       -I$(STAGING_DIR)/usr/include/libavformat \
++       -I$(STAGING_DIR)/usr/include/libavutil \
++       -I$(STAGING_DIR)/usr/include/libexif \
++       -I$(STAGING_DIR)/usr/include/uuid \
++       -I$(STAGING_DIR)/usr/include/vorbis \
++       -I$(ICONV_PREFIX)/include \
++       -I$(INTL_PREFIX)/include
++LDFLAGS = -L$(STAGING_DIR)/usr/lib \
++       -L$(ICONV_PREFIX)/lib \
++       -L$(INTL_PREFIX)/include \
++       -Wl,-rpath=$(STAGING_DIR)/usr/lib \
++       -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
++
+ #STATIC_LINKING: CFLAGS += -DSTATIC
+ #STATIC_LINKING: LDFLAGS = -static
+ CC = gcc
+@@ -37,7 +50,7 @@ BASEOBJS = minidlna.o upnphttp.o upnpdes
+ ALLOBJS = $(BASEOBJS) $(LNXOBJS)
+-LIBS = -lpthread -lexif -ljpeg -lsqlite3 -lavformat -lavutil -lavcodec -lid3tag -lFLAC -logg -lvorbis
++LIBS = -liconv -lpthread -lexif -ljpeg -lsqlite3 -lavformat -lavutil -lavcodec -lid3tag -lFLAC -logg -lvorbis -luuid
+ #STATIC_LINKING: LIBS = -lvorbis -logg -lm -lsqlite3 -lpthread -lexif -ljpeg -lFLAC -lm -lid3tag -lz -lavformat -lavutil -lavcodec -lm
+ TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
+@@ -62,7 +75,7 @@ install:     minidlna
+       $(INSTALL) -d $(ETCINSTALLDIR)
+       $(INSTALL) --mode=0644 minidlna.conf $(ETCINSTALLDIR)
+-minidlna:     $(BASEOBJS) $(LNXOBJS) $(LIBS)
++minidlna:     $(BASEOBJS) $(LNXOBJS)
+       @echo Linking $@
+       @$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $(BASEOBJS) $(LNXOBJS) $(LIBS)