Convert pptpd to new packaging style
authorNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 00:03:33 +0000 (00:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 19 May 2005 00:03:33 +0000 (00:03 +0000)
SVN-Revision: 942

openwrt/package/pptpd/Config.in
openwrt/package/pptpd/Makefile
openwrt/package/pptpd/files/options.pptpd [new file with mode: 0644]
openwrt/package/pptpd/files/pptpd.conf [new file with mode: 0644]
openwrt/package/pptpd/files/pptpd.init [new file with mode: 0644]
openwrt/package/pptpd/ipkg/CONTROL/conffiles [deleted file]
openwrt/package/pptpd/ipkg/etc/ppp/pptp-server-options [deleted file]
openwrt/package/pptpd/ipkg/etc/pptpd.conf [deleted file]
openwrt/package/pptpd/ipkg/pptpd.conffiles [new file with mode: 0644]
openwrt/package/pptpd/ipkg/pptpd.control [new file with mode: 0644]
openwrt/package/pptpd/pptpd.control [deleted file]

index 69150291642579945a6b8b2dff223ee30896815d..ab495f0642ae84890d6b060cb4899967f3b0b74f 100644 (file)
@@ -1,7 +1,12 @@
 config BR2_PACKAGE_PPTPD
-       tristate "PPTP Server"
+       prompt "pptpd - a PPTP (Point-to-Point Tunneling Protocol) server"
+       tristate
        default m if CONFIG_DEVEL
        select BR2_PACKAGE_KMOD_GRE
        select BR2_PACKAGE_PPP
        help
-         A Point-to-Point Tunneling Protocol Server 
+         A Point-to-Point Tunneling Protocol server
+         
+         http://poptop.sourceforge.net/
+         
+
index 31608f95eac15439ea566087d9478af6f6f6f71c..5880799fa36b28ee70b1f94e53360dc529f3400c 100644 (file)
@@ -9,65 +9,61 @@ PKG_MD5SUM:=a521e40ca304b0c125cc25f9b9d03324
 
 PKG_SOURCE_URL:=@SF/poptop
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
 
-$(DL_DIR)/$(PKG_SOURCE):
-        $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
+$(eval $(call PKG_template,PPTPD,pptpd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
-       (cd $(PKG_BUILD_DIR) ; \
-       $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       ./configure \
-         --target=$(GNU_TARGET_NAME) \
-         --host=$(GNU_TARGET_NAME) \
-         --build=$(GNU_HOST_NAME) \
-         --prefix=/usr \
-         --exec-prefix=/usr \
-         --bindir=/usr/bin \
-         --sbindir=/usr/sbin \
-         --libexecdir=/usr/lib \
-         --datadir=/usr/share \
-         --infodir=/usr/share/info \
-         --mandir=/usr/share/man \
-         --localstatedir=/var \
-         --sysconfdir=/etc \
-         $(DISABLE_NLS) \
-         --with-pppd-ip-alloc)
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
+                 --with-pppd-ip-alloc \
+       )
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+$(PKG_BUILD_DIR)/.built:
        $(MAKE) -C $(PKG_BUILD_DIR) \
-        CC=$(TARGET_CC) \
-        CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
-        all
-
-$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp -a ./ipkg/* $(PKG_IPK_DIR)/
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       cp $(PKG_BUILD_DIR)/pptpd $(PKG_IPK_DIR)/usr/sbin/
-       cp $(PKG_BUILD_DIR)/pptpctrl $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PACKAGE_DIR)
-       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-
-$(IPKG_STATE_DIR)/info/pptpd.list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/pptpd.list
+               CC=$(TARGET_CC) \
+               CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALL="install" \
+               all install
+       touch $(PKG_BUILD_DIR)/.built
 
-clean:
-       rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+$(IPKG_PPTPD):
+       install -d -m0755 $(IDIR_PPTPD)/etc
+       install -m0644 ./files/pptpd.conf $(IDIR_PPTPD)/etc/
+       install -d -m0755 $(IDIR_PPTPD)/etc/init.d
+       install -m0644 ./files/pptpd.init $(IDIR_PPTPD)/etc/init.d/pptpd
+       install -d -m0755 $(IDIR_PPTPD)/etc/ppp
+       install -m0644 ./files/options.pptpd $(IDIR_PPTPD)/etc/ppp/
+       install -d -m0755 $(IDIR_PPTPD)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(IDIR_PPTPD)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(IDIR_PPTPD)/usr/sbin/
+       $(RSTRIP) $(IDIR_PPTPD)
+       $(IPKG_BUILD) $(IDIR_PPTPD) $(PACKAGE_DIR)
diff --git a/openwrt/package/pptpd/files/options.pptpd b/openwrt/package/pptpd/files/options.pptpd
new file mode 100644 (file)
index 0000000..5dd2daf
--- /dev/null
@@ -0,0 +1,23 @@
+#debug
+#logfile /tmp/pptp-server.log
+172.16.1.1:
+auth
+name "pptp-server"
+lcp-echo-failure 3
+lcp-echo-interval 60
+default-asyncmap
+mtu 1482
+mru 1482
+nobsdcomp
+nodeflate
+#noproxyarp
+#nomppc
+mppe required,no40,no56,stateless
+require-mschap-v2
+refuse-chap
+refuse-mschap
+refuse-eap
+refuse-pap
+#ms-dns 172.16.1.1
+#plugin radius.so
+#radius-config-file /etc/radius.conf
diff --git a/openwrt/package/pptpd/files/pptpd.conf b/openwrt/package/pptpd/files/pptpd.conf
new file mode 100644 (file)
index 0000000..e9ac115
--- /dev/null
@@ -0,0 +1,5 @@
+#debug
+option /etc/ppp/pptp-server-options
+speed 115200
+stimeout 10
+#localip & remoteip are not needed, ip management is done by pppd
diff --git a/openwrt/package/pptpd/files/pptpd.init b/openwrt/package/pptpd/files/pptpd.init
new file mode 100644 (file)
index 0000000..79db864
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+BIN=pptpd
+DEFAULT=/etc/default/$BIN
+RUN_D=/var/run
+PID_F=$RUN_D/$BIN.pid
+[ -f $DEFAULT ] && . $DEFAULT
+
+case $1 in
+ start)
+  mkdir -p $RUN_D
+  for m in arc4 sha1 shlc ppp_generic ppp_async ppp_mppe_mppc; do
+   insmod $m >/dev/null 2>&1
+  done
+  $BIN $OPTIONS
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F)
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/pptpd/ipkg/CONTROL/conffiles b/openwrt/package/pptpd/ipkg/CONTROL/conffiles
deleted file mode 100644 (file)
index 34a387b..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-/etc/ppp/pptp-server-options
-/etc/pptpd.conf
diff --git a/openwrt/package/pptpd/ipkg/etc/ppp/pptp-server-options b/openwrt/package/pptpd/ipkg/etc/ppp/pptp-server-options
deleted file mode 100644 (file)
index 5dd2daf..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-#debug
-#logfile /tmp/pptp-server.log
-172.16.1.1:
-auth
-name "pptp-server"
-lcp-echo-failure 3
-lcp-echo-interval 60
-default-asyncmap
-mtu 1482
-mru 1482
-nobsdcomp
-nodeflate
-#noproxyarp
-#nomppc
-mppe required,no40,no56,stateless
-require-mschap-v2
-refuse-chap
-refuse-mschap
-refuse-eap
-refuse-pap
-#ms-dns 172.16.1.1
-#plugin radius.so
-#radius-config-file /etc/radius.conf
diff --git a/openwrt/package/pptpd/ipkg/etc/pptpd.conf b/openwrt/package/pptpd/ipkg/etc/pptpd.conf
deleted file mode 100644 (file)
index e9ac115..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-#debug
-option /etc/ppp/pptp-server-options
-speed 115200
-stimeout 10
-#localip & remoteip are not needed, ip management is done by pppd
diff --git a/openwrt/package/pptpd/ipkg/pptpd.conffiles b/openwrt/package/pptpd/ipkg/pptpd.conffiles
new file mode 100644 (file)
index 0000000..c5afda9
--- /dev/null
@@ -0,0 +1,2 @@
+/etc/ppp/options.pptpd
+/etc/pptpd.conf
diff --git a/openwrt/package/pptpd/ipkg/pptpd.control b/openwrt/package/pptpd/ipkg/pptpd.control
new file mode 100644 (file)
index 0000000..7d0a19b
--- /dev/null
@@ -0,0 +1,7 @@
+Package: pptpd
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: a Point-to-Point Tunneling Protocol (PPTP) server
+Depends: ppp, kmod-gre
diff --git a/openwrt/package/pptpd/pptpd.control b/openwrt/package/pptpd/pptpd.control
deleted file mode 100644 (file)
index 7d0a19b..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: pptpd
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot internal
-Description: a Point-to-Point Tunneling Protocol (PPTP) server
-Depends: ppp, kmod-gre