[packages] weechat: fix autoreconf
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 3 Feb 2011 20:04:30 +0000 (20:04 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 3 Feb 2011 20:04:30 +0000 (20:04 +0000)
SVN-Revision: 25350

net/weechat/Makefile
net/weechat/patches/001-cross_compiling.patch
net/weechat/patches/003-lua_flags.patch
net/weechat/patches/004-automake-compat.patch [new file with mode: 0644]

index 480b28c6dcd9080d903806ef3072b4cee81eaf70..69a411fec14728cbb7a1e0c0879682c1dce9cd80 100644 (file)
@@ -71,7 +71,6 @@ endef
 
 CONFIGURE_ARGS+= \
        --with-debug=0 \
 
 CONFIGURE_ARGS+= \
        --with-debug=0 \
-       --with-libgnutls-prefix=$(STAGING_DIR)/usr \
        --without-doc-xsl-prefix \
        --with-libiconv-prefix="$(ICONV_PREFIX)" \
        --without-libintl-prefix \
        --without-doc-xsl-prefix \
        --with-libiconv-prefix="$(ICONV_PREFIX)" \
        --without-libintl-prefix \
index 515646fd7a5c7c056640a850c1855ac2a018be87..a6a11411602ad78f8c3921a77fae0217609cfc9b 100644 (file)
@@ -1,8 +1,6 @@
-Index: weechat-0.2.5/configure
-===================================================================
---- weechat-0.2.5.orig/configure       2007-06-30 17:15:36.000000000 +0200
-+++ weechat-0.2.5/configure    2007-06-30 17:15:36.000000000 +0200
-@@ -29349,8 +29349,7 @@
+--- a/configure
++++ b/configure
+@@ -29625,8 +29625,7 @@ echo $ECHO_N "checking for iconv usabili
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
    { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
  See \`config.log' for more details." >&5
  echo "$as_me: error: cannot run test program while cross compiling
@@ -12,7 +10,7 @@ Index: weechat-0.2.5/configure
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
  else
    cat >conftest.$ac_ext <<_ACEOF
  /* confdefs.h.  */
-@@ -29407,7 +29406,6 @@
+@@ -29683,7 +29682,6 @@ echo "${ECHO_T}no" >&6; }
  echo "${ECHO_T}yes" >&6; }
    fi
  fi
  echo "${ECHO_T}yes" >&6; }
    fi
  fi
@@ -20,7 +18,7 @@ Index: weechat-0.2.5/configure
  if test "x$iconv_found" = "xno" ; then
     { { echo "$as_me:$LINENO: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
  if test "x$iconv_found" = "xno" ; then
     { { echo "$as_me:$LINENO: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
-@@ -29416,8 +29414,7 @@
+@@ -29692,8 +29690,7 @@ if test "x$iconv_found" = "xno" ; then
  echo "$as_me: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
  *** Try to install them with your software package manager.
  echo "$as_me: error:
  *** Iconv headers and/or libraries couldn't be found in your system.
  *** Try to install them with your software package manager.
@@ -30,3 +28,29 @@ Index: weechat-0.2.5/configure
  fi
  
  # ------------------------------------------------------------------------------
  fi
  
  # ------------------------------------------------------------------------------
+--- a/configure.in
++++ b/configure.in
+@@ -208,22 +208,8 @@ if test "x$ac_found_iconv_header" = "xye
+    if test "x$ac_found_iconv_lib" = "xyes" ; then
+       ICONV_LFLAGS="-liconv"
+       LIBS="$LIBS $ICONV_LFLAGS"
++      iconv_found="yes"
+    fi
+-   AC_MSG_CHECKING(for iconv usability in programs)   
+-   AC_TRY_RUN([
+-      #include <iconv.h>
+-      int main(int argc, char **argv) {
+-          iconv_t conv = iconv_open("ISO8859-1", "UTF-8");
+-            if (conv != (iconv_t) -1) {
+-            return 0;
+-            }
+-          return 1;
+-      }],iconv_found="yes")
+-  if test "x$iconv_found" = "xno" ; then
+-     AC_MSG_RESULT(no)
+-  else
+-     AC_MSG_RESULT(yes)
+-  fi
+ fi
+ if test "x$iconv_found" = "xno" ; then
index 8152cbfbf9bbed5f3e8baeb71385669e16819331..906674bde3bed12a5949dcd69b870141a2de6443 100644 (file)
@@ -1,7 +1,6 @@
-diff -urN weechat-0.2.6/configure weechat-0.2.6.new/configure
---- weechat-0.2.6/configure    2007-09-05 16:16:21.000000000 +0200
-+++ weechat-0.2.6.new/configure        2008-01-20 16:29:38.000000000 +0100
-@@ -30180,14 +30180,6 @@
+--- a/configure
++++ b/configure
+@@ -30177,14 +30177,6 @@ fi
    test -n "$LUACONFIG" && break
  done
  
    test -n "$LUACONFIG" && break
  done
  
diff --git a/net/weechat/patches/004-automake-compat.patch b/net/weechat/patches/004-automake-compat.patch
new file mode 100644 (file)
index 0000000..2bcf2dc
--- /dev/null
@@ -0,0 +1,51 @@
+--- a/configure.in
++++ b/configure.in
+@@ -176,21 +176,7 @@ fi
+ #    WXWIDGETS_LIBS=""
+ #fi
+-if test "x$enable_gtk" = "xyes" ; then
+-    AM_PATH_GTK_2_0(2.4.0, LIBGTK_FOUND=1, LIBGTK_FOUND=0)
+-    if test "$LIBGTK_FOUND" = "0" ; then
+-        AC_MSG_WARN([
+-*** Gtk library not found!
+-*** WeeChat will be built without Gtk support.])
+-        enable_gtk="no"
+-        not_found="$not_found gtk"
+-    else
+-        GTK_CFLAGS=`pkg-config --cflags gtk+-2.0`
+-        GTK_LIBS=`pkg-config --libs gtk+-2.0`
+-        AC_SUBST(GTK_CFLAGS)
+-        AC_SUBST(GTK_LIBS)
+-    fi
+-fi
++enable_gtk="no"
+ # ------------------------------------------------------------------------------
+ #                                  iconv
+@@ -586,20 +572,11 @@ fi
+ # ------------------------------------------------------------------------------
+ if test "x$enable_gnutls" = "xyes" ; then
+-    found_gnutls="no"
+-    AM_PATH_LIBGNUTLS( 1.0.0, found_gnutls=yes, AC_MSG_WARN([[
+-*** libgnutls was not found. You may want to get it from ftp://ftp.gnutls.org/pub/gnutls/
+-*** WeeChat will be built without GnuTLS support.]]))
+-    if test "x$found_gnutls" = "xyes" ; then
+-        GNUTLS_CFLAGS=`libgnutls-config --cflags`
+-        GNUTLS_LFLAGS=`libgnutls-config --libs`
+-        AC_SUBST(GNUTLS_CFLAGS)
+-        AC_SUBST(GNUTLS_LFLAGS)
+-        AC_DEFINE(HAVE_GNUTLS)
+-    else
+-        enable_gnutls="no"
+-        not_found="$not_found gnutls"
+-    fi
++    GNUTLS_CFLAGS=`pkg-config --cflags gnutls`
++    GNUTLS_LFLAGS=`pkg-config --libs gnutls`
++    AC_SUBST(GNUTLS_CFLAGS)
++    AC_SUBST(GNUTLS_LFLAGS)
++    AC_DEFINE(HAVE_GNUTLS)
+ fi
+ # ------------------------------------------------------------------------------