[packages] hping3: refresh patches
authorNicolas Thill <nico@openwrt.org>
Thu, 1 Apr 2010 05:57:20 +0000 (05:57 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 1 Apr 2010 05:57:20 +0000 (05:57 +0000)
SVN-Revision: 20645

net/hping3/patches/100-makefile.patch
net/hping3/patches/101-endianness.patch
net/hping3/patches/102-lib_rename.patch

index 61f0cf4fface363db7fa5981b01df5b73868508f..abf3a0db418fb10dedde5898e589a32df87450f3 100644 (file)
@@ -1,5 +1,5 @@
---- hping3-20051105_orig/Makefile      2005-11-05 11:31:41.000000000 +0100
-+++ hping3-20051105/Makefile   2009-02-26 13:44:40.000000000 +0100
+--- a/Makefile
++++ b/Makefile
 @@ -6,15 +6,15 @@
  # $date: Sun Jul 25 17:56:15 MET DST 1999$ 
  # $rev: 3$ 
@@ -22,7 +22,7 @@
  PCAP=-lpcap
  
  ARSOBJ = ars.o apd.o split.o rapd.o
-@@ -50,20 +50,16 @@
+@@ -50,20 +50,16 @@ libars.a: $(ARSOBJ)
        $(RANLIB) $@
  
  hping3: byteorder.h $(OBJ)
index 49249a0a4318725db3749faed6d1febce3b530ae..9c89aeebe092845be714411e66597209a4ec82a1 100644 (file)
@@ -1,5 +1,5 @@
---- hping3-20051105_orig/hping2.h      2004-06-04 09:22:38.000000000 +0200
-+++ hping3-20051105/hping2.h   2009-02-26 15:42:14.000000000 +0100
+--- a/hping2.h
++++ b/hping2.h
 @@ -13,6 +13,7 @@
  #ifndef _HPING2_H
  #define _HPING2_H
@@ -21,7 +21,7 @@
          __u8    version:4,
                  ihl:4;
  #else
-@@ -287,10 +288,10 @@
+@@ -287,10 +288,10 @@ struct mytcphdr {
        __u16   th_dport;               /* destination port */
        __u32   th_seq;                 /* sequence number */
        __u32   th_ack;                 /* acknowledgement number */
@@ -34,9 +34,8 @@
        __u8    th_off:4,               /* data offset */
                th_x2:4;                /* (unused) */
  #else
-diff -urN hping3-20051105/bytesex.h hping3-20051105.new/bytesex.h
---- hping3-20051105/bytesex.h  2003-08-31 19:23:48.000000000 +0200
-+++ hping3-20051105.new/bytesex.h      2009-04-13 15:14:52.000000000 +0200
+--- a/bytesex.h
++++ b/bytesex.h
 @@ -9,9 +9,11 @@
  
  #if   defined(__i386__) \
index 77943c1d93c67d7d85bd2d80aff7f931549ff362..c5d102c3368a6e0253a9a62ef4dc90b0a86a7517 100644 (file)
@@ -1,5 +1,5 @@
---- hping3-20051105_orig/libpcap_stuff.c       2004-04-10 01:38:56.000000000 +0200
-+++ hping3-20051105/libpcap_stuff.c    2009-02-26 15:26:26.000000000 +0100
+--- a/libpcap_stuff.c
++++ b/libpcap_stuff.c
 @@ -17,7 +17,7 @@
  #include <stdlib.h>
  #include <sys/ioctl.h>