don't try to package ipt_SNAT and ipt_DNAT when making kernel module packages
authorFelix Fietkau <nbd@openwrt.org>
Mon, 31 Jul 2006 16:39:58 +0000 (16:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 31 Jul 2006 16:39:58 +0000 (16:39 +0000)
SVN-Revision: 4354

openwrt/include/netfilter.mk

index d4ec0f3915db9e7fd4b19537968cf16bdf57e017..ba1512e14abcc86ccdd697f37ecb34d96806a422 100644 (file)
@@ -77,7 +77,9 @@ IPT_IPSEC-$(CONFIG_IP_NF_MATCH_AH) += $(P_V4)ipt_ah
 IPT_IPSEC-$(CONFIG_NETFILTER_XT_MATCH_ESP) += $(P_XT)xt_esp
 
 IPT_NAT-m :=
-IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+ifneq ($(NF_KMOD),1)
+  IPT_NAT-$(CONFIG_IP_NF_NAT) += $(P_V4)ipt_SNAT $(P_V4)ipt_DNAT
+endif
 IPT_NAT-$(CONFIG_IP_NF_TARGET_MASQUERADE) += $(P_V4)ipt_MASQUERADE
 IPT_NAT-$(CONFIG_IP_NF_TARGET_MIRROR) += $(P_V4)ipt_MIRROR
 IPT_NAT-$(CONFIG_IP_NF_TARGET_REDIRECT) += $(P_V4)ipt_REDIRECT