packages/net/openvpn: add uci example for custom config files
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 27 Nov 2008 22:39:59 +0000 (22:39 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 27 Nov 2008 22:39:59 +0000 (22:39 +0000)
SVN-Revision: 13386

net/openvpn/Makefile
net/openvpn/files/openvpn.config

index e3a6f2a633909623e09be273bc8ee15273f8b7ea..6a680aed08dcf8d1a55f0346690add7edbe8d933 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openvpn
 PKG_VERSION:=2.0.9
 
 PKG_NAME:=openvpn
 PKG_VERSION:=2.0.9
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://openvpn.net/release @SF/openvpn
index e88f1a09913baffe053e2dd1cfbaf5841ba16805..03e6a5307081c9e8c86392aea3a5cedd51342e45 100644 (file)
@@ -1,7 +1,20 @@
 package openvpn
 
 #################################################
 package openvpn
 
 #################################################
-# Sample OpenVPN 2.0 config file for            #
+# Sample to include a custom config file.       #
+#################################################
+
+config openvpn custom_config
+
+       # Set to 1 to enable this instance:
+       option enable 0
+
+       # Include OpenVPN configuration
+       option config /etc/openvpn/my-vpn.conf
+
+
+#################################################
+# Sample OpenVPN 2.0 uci config for             #
 # multi-client server.                          #
 #################################################
 
 # multi-client server.                          #
 #################################################
 
@@ -272,7 +285,7 @@ config openvpn sample_server
 
 
 ##############################################
 
 
 ##############################################
-# Sample client-side OpenVPN 2.0 config file #
+# Sample client-side OpenVPN 2.0 uci config  #
 # for connecting to multi-client server.     #
 ##############################################
 
 # for connecting to multi-client server.     #
 ##############################################