port libvorbisidec to buildroot-ng
authorNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 23:04:12 +0000 (23:04 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 22 Jul 2006 23:04:12 +0000 (23:04 +0000)
SVN-Revision: 4226

libs/libvorbisidec/Makefile [new file with mode: 0644]

diff --git a/libs/libvorbisidec/Makefile b/libs/libvorbisidec/Makefile
new file mode 100644 (file)
index 0000000..5032e7d
--- /dev/null
@@ -0,0 +1,97 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libvorbisidec
+PKG_VERSION:=1.2.0-dave
+PKG_RELEASE:=1
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://users.tpg.com.au/davico/openwrt/
+PKG_MD5SUM:=cb8e51aab92ef164f8e0e8853f7164fa
+PKG_CAT:=zcat
+
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libvorbisidec
+  SECTION:=libs
+  CATEGORY:=Libraries
+  TITLE:=A fixed-point Ogg/Vorbis decoder library
+  DESCRIPTION:=A fixed-point Ogg/Vorbis decoder library.\\\
+    libvorbisidec is "tremor", a fixed-point implementation of libvorbis.\\\
+    It also has libogg built-in. It is suitable as a replacement for \\\
+    libvorbis and libogg in tremor-aware applications.\\\
+    Tremor is a decoder only. 
+  URL:=http://http://wiki.xiph.org/index.php/Tremor
+endef
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(strip $(TARGET_CFLAGS))" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+       );
+endef
+
+define Build/Compile
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+endef
+
+define Package/libvorbisidec/install
+       install -m0755 -d $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.so.* $(1)/usr/lib/
+endef
+
+define Build/InstallDev
+       mkdir -p $(STAGING_DIR)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/tremor $(STAGING_DIR)/usr/include/
+       mkdir -p $(STAGING_DIR)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libvorbisidec.{a,so*} $(STAGING_DIR)/usr/lib/
+endef
+
+define Build/UninstallDev
+       rm -rf \
+               $(STAGING_DIR)/usr/include/tremor \
+               $(STAGING_DIR)/usr/lib/libvorbisidec.{a,so*}
+endef
+
+$(eval $(call BuildPackage,libvorbisidec))