[8.09] merge r16488
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Jun 2009 11:12:03 +0000 (11:12 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 17 Jun 2009 11:12:03 +0000 (11:12 +0000)
SVN-Revision: 16489

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index da26f2920fd33daaf7fdfb66d537f0cb48a9fe3d..ac16eca4909aee7f25db239796c59970cff360e7 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=14.1
+PKG_RELEASE:=14.2
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
 
 PKG_FILE_DEPEND:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 9ba9e23e7e8067264df31c7f1f553a5c28d61156..93dafc4d9ec1490b79494fda28bf9ec986b6e4ab 100644 (file)
@@ -134,12 +134,12 @@ jffs2_copy_config() {
 }
 
 default_do_upgrade() {
 }
 
 default_do_upgrade() {
+       sync
        if [ "$SAVE_CONFIG" -eq 1 -a -z "$USE_REFRESH" ]; then
                get_image "$1" | mtd -j "$CONF_TAR" write - "${PART_NAME:-image}"
        else
                get_image "$1" | mtd write - "${PART_NAME:-image}"
        fi
        if [ "$SAVE_CONFIG" -eq 1 -a -z "$USE_REFRESH" ]; then
                get_image "$1" | mtd -j "$CONF_TAR" write - "${PART_NAME:-image}"
        else
                get_image "$1" | mtd write - "${PART_NAME:-image}"
        fi
-       sync
 }
 
 do_upgrade() {
 }
 
 do_upgrade() {
@@ -149,7 +149,7 @@ do_upgrade() {
        else
                default_do_upgrade "$ARGV"
        fi
        else
                default_do_upgrade "$ARGV"
        fi
-       
+
        [ "$SAVE_CONFIG" -eq 1 -a -n "$USE_REFRESH" ] && {
                v "Refreshing partitions"
                if type 'platform_refresh_partitions' >/dev/null 2>/dev/null; then
        [ "$SAVE_CONFIG" -eq 1 -a -n "$USE_REFRESH" ] && {
                v "Refreshing partitions"
                if type 'platform_refresh_partitions' >/dev/null 2>/dev/null; then
@@ -167,7 +167,8 @@ do_upgrade() {
        [ -n "$DELAY" ] && sleep "$DELAY"
        ask_bool 1 "Reboot" && {
                v "Rebooting system..."
        [ -n "$DELAY" ] && sleep "$DELAY"
        ask_bool 1 "Reboot" && {
                v "Rebooting system..."
-               echo b 2>/dev/null >/proc/sysrq-trigger
                reboot
                reboot
+               sleep 5
+               echo b 2>/dev/null >/proc/sysrq-trigger
        }
 }
        }
 }