update lighttpd to new upstream release (v1.4.9), add -mod-evasive subpackage.
authorNicolas Thill <nico@openwrt.org>
Fri, 20 Jan 2006 15:33:47 +0000 (15:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 20 Jan 2006 15:33:47 +0000 (15:33 +0000)
SVN-Revision: 3028

openwrt/package/lighttpd/Config.in
openwrt/package/lighttpd/Makefile
openwrt/package/lighttpd/ipkg/lighttpd-mod-evasive.control [new file with mode: 0644]

index cf9dedf3959661b3ba923853beb4eb79d59add53..a083928241093a1bd4d97b42023a3030bda18add 100644 (file)
@@ -37,6 +37,12 @@ config BR2_PACKAGE_LIGHTTPD_MOD_CGI
        default m if CONFIG_DEVEL
        depends BR2_PACKAGE_LIGHTTPD
 
        default m if CONFIG_DEVEL
        depends BR2_PACKAGE_LIGHTTPD
 
+config BR2_PACKAGE_LIGHTTPD_MOD_EVASIVE
+       prompt   "lighttpd-mod-evasive............ Evasive module"
+       tristate 
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_LIGHTTPD
+
 config BR2_PACKAGE_LIGHTTPD_MOD_EXPIRE
        prompt   "lighttpd-mod-expire............. Expire module"
        tristate 
 config BR2_PACKAGE_LIGHTTPD_MOD_EXPIRE
        prompt   "lighttpd-mod-expire............. Expire module"
        tristate 
index 65a8d35141bcbb5727e4289f5144d44681748757..401895c388a497b0f3d3996d1c8aab6b455d213a 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lighttpd
-PKG_VERSION:=1.4.8
+PKG_VERSION:=1.4.9
 PKG_RELEASE:=1
 PKG_RELEASE:=1
-PKG_MD5SUM:=7d7790ef95ff5755f73bfcda4f13696d
+PKG_MD5SUM:=20a171774a0615069de3704db52483aa
 
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 PKG_SOURCE_URL:=http://www.lighttpd.net/download/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -31,6 +31,7 @@ $(eval $(call PKG_template,LIGHTTPD_MOD_ACCESSLOG,lighttpd-mod-accesslog,$(PKG_V
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_ALIAS,lighttpd-mod-alias,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_AUTH,lighttpd-mod-auth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_CGI,lighttpd-mod-cgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,LIGHTTPD_MOD_EVASIVE,lighttpd-mod-evasive,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_EXPIRE,lighttpd-mod-expire,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_FASTCGI,lighttpd-mod-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_EXPIRE,lighttpd-mod-expire,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_FASTCGI,lighttpd-mod-fastcgi,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,LIGHTTPD_MOD_PROXY,lighttpd-mod-proxy,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -46,6 +47,7 @@ $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ACCESSLOG,accesslog))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_ALIAS,alias))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_AUTH,auth))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_CGI,cgi))
+$(eval $(call PKG_mod_template,LIGHTTPD_MOD_EVASIVE,evasive))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_EXPIRE,expire))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_FASTCGI,fastcgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_EXPIRE,expire))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_FASTCGI,fastcgi))
 $(eval $(call PKG_mod_template,LIGHTTPD_MOD_PROXY,proxy))
diff --git a/openwrt/package/lighttpd/ipkg/lighttpd-mod-evasive.control b/openwrt/package/lighttpd/ipkg/lighttpd-mod-evasive.control
new file mode 100644 (file)
index 0000000..dd00165
--- /dev/null
@@ -0,0 +1,5 @@
+Package: lighttpd-mod-evasive
+Priority: optional
+Section: net
+Description: Evasive module for lighttpd
+Depends: lighttpd