Fix ip path checking and make 6scripts depend on kmod-ipv6 (#4085)
authorFlorian Fainelli <florian@openwrt.org>
Sat, 11 Oct 2008 13:18:04 +0000 (13:18 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sat, 11 Oct 2008 13:18:04 +0000 (13:18 +0000)
SVN-Revision: 12953

ipv6/6scripts/Makefile
ipv6/6scripts/files/6tunnel.init

index 5600ff0be049ead9d3fde4b44a7f23f016a4fccd..2b398d08085b5a756a24f7e2046d4ca3d34f83ee 100644 (file)
@@ -17,6 +17,7 @@ include $(INCLUDE_DIR)/package.mk
 define Package/6scripts
   SECTION:=ipv6
   CATEGORY:=IPv6
+  DEPENDS:=+kmod-ipv6
   TITLE:=IPv6 scripts
 endef
 
index cd4e1fc0274c2fc5f705c9ad852970db32a52a82..84ba325632670a206805a2c7af23e534c97a89aa 100644 (file)
@@ -46,11 +46,7 @@ stop_service() {
        ip tunnel del $tnlifname
 }
 start() {
-       if ! [ -f /proc/net/if_inet6 ]; then
-               echo "IPv6 not enabled, install kmod-ipv6";
-               exit 1;
-       fi
-       if ! [ -x /sbin/ip ]; then
+       if ! [ -x /usr/sbin/ip ]; then
                echo "ip is required to setup the tunnel";
                exit 1;
        fi