Add missing ulogd dependencies
authorNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 01:38:47 +0000 (01:38 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 21 May 2005 01:38:47 +0000 (01:38 +0000)
SVN-Revision: 999

openwrt/package/Makefile

index e360e8685fad1279b9536021b8fa02715e561fed..e8a2a914e903425c7b0a3c0f5ebb45c81c7ce864 100644 (file)
@@ -166,6 +166,14 @@ ifeq ($(BR2_PACKAGE_SNORT_ENABLE_INLINE),y)
 snort-compile: iptables-compile
 endif
 
+ulogd-compile: iptables-compile
+ifneq ($(BR2_PACKAGE_ULOGD_MYSQL),)
+ulogd-compile: mysql-compile
+endif
+ifneq ($(BR2_PACKAGE_ULOGD_PGSQL),)
+ulogd-compile: postgresql-compile
+endif
+
 sdk-compile: $(DEV_LIBS_COMPILE) $(SDK_DEFAULT_COMPILE) openwrt-install
 $(patsubst %,%-prepare,$(package-y) $(package-m) $(package-)): linux-install