[brcm63xx] add support for DSL-2640B rev B2
authorFlorian Fainelli <florian@openwrt.org>
Fri, 20 May 2011 10:06:22 +0000 (10:06 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 20 May 2011 10:06:22 +0000 (10:06 +0000)
Signed-off-by: Adrian Feliks <mexit@o2.pl>
SVN-Revision: 26958

target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network [new file with mode: 0644]
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network b/target/linux/brcm63xx/base-files/etc/defconfig/D-4P-W/network
new file mode 100644 (file)
index 0000000..fa4844d
--- /dev/null
@@ -0,0 +1,14 @@
+# Copyright (C) 2010 OpenWrt.org
+
+config interface loopback
+       option ifname   lo
+       option proto    static
+       option ipaddr   127.0.0.1
+       option netmask  255.0.0.0
+
+config interface lan
+       option ifname   eth0
+       option type     bridge
+       option proto    static
+       option ipaddr   192.168.1.1
+       option netmask  255.255.255.0
index 2c62928a555c03279f345a5cd67d96afec14f2d4..d2ffabd176fcb17579cc9afa8a68ec0a3cf3a976 100755 (executable)
@@ -59,6 +59,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       "bcm63xx/D-4P-W "*)
+               status_led="power:green"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        *)
                ;;
        esac
index f1fa4f540e85606b99268df110a2a8e692886e7d..8b157711053b17338d0118bbb30133c72b6e9563 100644 (file)
@@ -189,8 +189,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-10,6348,DG834GT_DG834PN)
        # Belkin f5d7633
        $(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
-       # D-Link DSL-2640B
-       $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B)
+       # D-Link DSL-2640B, rev B2
+       $(call Image/Build/CFE,$(1),D-4P-W,6348,DSL2640B-B2)
        # D-Link DSL-2740B/DSL-2741B, rev C2
        $(call Image/Build/CFEFIXUP,$(1),96358GW,AW4139,6358,DSL274XB-C2)
        # D-Link DSL-2740B/DSL-2741B, rev C3
diff --git a/target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch b/target/linux/brcm63xx/patches-2.6.37/421-board-D4PW_correction.patch
new file mode 100644 (file)
index 0000000..540626a
--- /dev/null
@@ -0,0 +1,70 @@
+--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
++++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
+@@ -522,42 +522,48 @@ static struct board_info __initdata boar
+       .name                           = "D-4P-W",
+       .expected_cpu_id                = 0x6348,
+-      .has_enet0                      = 1,
+-      .has_enet1                      = 1,
++      .has_enet1                      = 1,    
+       .has_pci                        = 1,
+-
+-      .enet0 = {
+-              .has_phy                = 1,
+-              .use_internal_phy       = 1,
+-      },
++      .has_uart0                      = 1,
++      
+       .enet1 = {
+               .force_speed_100        = 1,
+               .force_duplex_full      = 1,
+-      },
+-
+-      .has_ohci0                      = 1,
+-      .has_ehci0                      = 1,
++      },      
+       .leds = {
+               {
+-                      .name           = "ppp",
++                      .name           = "power:green",
++                      .gpio           = 0,
++                      .active_low     = 1,
++              },
++              {
++                      .name           = "status",
++                      .gpio           = 3,
++                      .active_low     = 1,                    
++              },
++              {
++                      .name           = "internet:green",
+                       .gpio           = 4,
+                       .active_low     = 1,
+               },
+               {
+-                      .name           = "ppp-fail",
++                      .name           = "internet:red",
+                       .gpio           = 5,
+                       .active_low     = 1,
+-              },
++              },              
++      },
++      
++      .buttons = {
+               {
+-                      .name           = "power",
+-                      .gpio           = 0,
++                      .desc           = "reset",
++                      .gpio           = 7,
+                       .active_low     = 1,
+-                      .default_trigger = "default-on",
+-
++                      .type           = EV_KEY,
++                      .code           = KEY_RESTART,
++                      .threshold      = 3,
+               },
+       },
+-
+ };
+ static struct board_info __initdata board_spw500v = {