[package] update radvd to 1.5, select kmod-ipv6 (#5966)
authorFlorian Fainelli <florian@openwrt.org>
Thu, 8 Oct 2009 09:34:36 +0000 (09:34 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 8 Oct 2009 09:34:36 +0000 (09:34 +0000)
SVN-Revision: 17992

ipv6/radvd/Makefile
ipv6/radvd/patches/001-fix_avr32_compile
ipv6/radvd/patches/002-no_libfl.patch

index 12c5bbcf4e6692b19b8ba07f659dfeeca8072a99..422325cb45d37d8bb7cb240653a5c1a82f660974 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=radvd
-PKG_VERSION:=1.4
+PKG_VERSION:=1.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
                http://download.sourcemage.org/mirror
-PKG_MD5SUM:=ad57121d57a716aa5db33668e4fb32c5
+PKG_MD5SUM:=78598b60ed9d64920739189c3dc0934d
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,6 +23,7 @@ define Package/radvd
   CATEGORY:=IPv6
   TITLE:=IPv6 Routing Advertisement Daemon
   URL:=http://v6web.litech.org/radvd/
+  DEPENDS:=+kmod-ipv6
 endef
 
 define Package/radvd/description
@@ -51,7 +52,7 @@ endef
 
 define Package/radvd/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/radvd.config $(1)/etc/config/radvd
+       $(INSTALL_CONF) ./files/radvd.config $(1)/etc/config/radvd
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/radvd.init $(1)/etc/init.d/radvd
        $(INSTALL_DIR) $(1)/usr/sbin
index a8a93f6919f13378d3a30e6df6c357f49e8cb278..050ae281a656bd0672bbfc16e396061ab90fab0c 100644 (file)
@@ -1,6 +1,6 @@
---- radvd-1.0/config.sub.orig  2008-05-16 13:20:02.000000000 -0500
-+++ radvd-1.0/config.sub       2008-05-16 13:20:23.000000000 -0500
-@@ -228,7 +228,7 @@
+--- a/config.sub
++++ b/config.sub
+@@ -228,7 +228,7 @@ case $basic_machine in
        | a29k \
        | alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
        | alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
@@ -9,7 +9,7 @@
        | c4x | clipper \
        | d10v | d30v | dsp16xx \
        | fr30 \
-@@ -282,7 +282,7 @@
+@@ -282,7 +282,7 @@ case $basic_machine in
        | alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
        | alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
        | arm-*  | armbe-* | armle-* | armv*-* \
index e17a127c95043f1b2f9509559ef9562852f6a4ca..26041b7142f22afff49f9654a9e0b00d434fa849 100644 (file)
@@ -1,6 +1,5 @@
-diff -urN radvd-0.7.3.old/scanner.l radvd-0.7.3/scanner.l
---- radvd-0.7.3.old/scanner.l  2004-10-26 07:30:34.000000000 +0200
-+++ radvd-0.7.3/scanner.l      2005-04-05 00:01:42.000000000 +0200
+--- a/scanner.l
++++ b/scanner.l
 @@ -21,6 +21,8 @@
  
  extern char *conf_file;