[packages] ulogd: compile with --export-dynamic to solve segfault in dlopen() (#8481)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 12:21:47 +0000 (12:21 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 8 May 2011 12:21:47 +0000 (12:21 +0000)
SVN-Revision: 26853

net/ulogd/Makefile

index c1dc32b0b93d59f747418fc6aaf2bc8381c82abf..ddfdc1c52c5d2e4a30393d692bca71e9ac81c87c 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -109,6 +109,7 @@ define Build/Compile
                        -I$(PKG_BUILD_DIR)/include/ulogd \
                        -I$(PKG_BUILD_DIR)/include \
                        -I$(PKG_BUILD_DIR)/libipulog/include \
                        -I$(PKG_BUILD_DIR)/include/ulogd \
                        -I$(PKG_BUILD_DIR)/include \
                        -I$(PKG_BUILD_DIR)/libipulog/include \
+                       -Wl,--export-dynamic \
                        $(TARGET_CPPFLAGS)" \
                all install
 endef
                        $(TARGET_CPPFLAGS)" \
                all install
 endef