packages/aprx: use new service functions
authorNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:23 +0000 (22:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 13 Nov 2011 22:15:23 +0000 (22:15 +0000)
SVN-Revision: 29048

net/aprx/Makefile
net/aprx/files/aprx.init

index 6a38e756a8d88f5fb39d6f227c6f147c0790a2de..77879644473974e2779085a12d3415619c1abfb9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=aprx
 PKG_REV:=421
 PKG_VERSION:=2.00_r$(PKG_REV)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://repo.ham.fi/svn/aprx/trunk/
index e2dcd89f41b9d44b8873b7a2d66910ee688be0e5..9682eeeb84adcd97d10456ca6ee1c3ebd3d2513d 100644 (file)
@@ -1,23 +1,15 @@
 #!/bin/sh /etc/rc.common
-#Init script for aprx
+# Copyright (C) 2008-2011 OpenWrt.org
 
 START=99
-APRX_BIN="/usr/sbin/aprx"
-APRX_LOG_DIR="/var/log/aprx"
-
-system_config() {
-       local cfg="$1"
-
-       config_get hostname "$cfg" hostname
-}
 
+SERVICE_USE_PID=1
 
 start() {
-       [ -x "$APRX_BIN" ] || return 1
-       [ -d "$APRX_LOG_DIR" ] || mkdir -p $APRX_LOG_DIR
-       $APRX_BIN
-       }
+       mkdir -m 0755 -p /var/log/aprx
+       service_start /usr/sbin/aprx
+}
 
 stop() {
-       killall aprx
+       service_stop /usr/sbin/aprx
 }