Add ar7-atm fixes by DerAgo, also fix compilation (the use of dumb inlining in protot...
authorFlorian Fainelli <florian@openwrt.org>
Tue, 24 Jul 2007 10:58:39 +0000 (10:58 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 24 Jul 2007 10:58:39 +0000 (10:58 +0000)
SVN-Revision: 8140

package/ar7-atm/patches/120-no_dumb_inline.patch [new file with mode: 0644]
package/ar7-atm/patches/130-powercutback.patch [new file with mode: 0644]
package/ar7-atm/patches/140-debug_mode.patch [new file with mode: 0644]

diff --git a/package/ar7-atm/patches/120-no_dumb_inline.patch b/package/ar7-atm/patches/120-no_dumb_inline.patch
new file mode 100644 (file)
index 0000000..f9c472f
--- /dev/null
@@ -0,0 +1,11 @@
+--- sangam_atm-07.01.00.10/tn7api.h    2006-10-26 16:48:34.000000000 +0200
++++ sangam_atm-07.01.00.10.new/tn7api.h        2007-07-24 12:43:04.000000000 +0200
+@@ -104,7 +104,7 @@
+ int tn7dsl_proc_write_stats(struct file *fp, const char * buf, unsigned long count, void * data);
+ int tn7dsl_proc_modem(char* buf, char **start, off_t offset, int count,int *eof, void *data);
+-inline int tn7dsl_handle_interrupt(void);
++int tn7dsl_handle_interrupt(void);
+ void tn7dsl_dslmod_sysctl_register(void);
+ void tn7dsl_dslmod_sysctl_unregister(void);
diff --git a/package/ar7-atm/patches/130-powercutback.patch b/package/ar7-atm/patches/130-powercutback.patch
new file mode 100644 (file)
index 0000000..0dc495d
--- /dev/null
@@ -0,0 +1,44 @@
+--- atm.old/tn7dsl.c   2006-10-26 16:48:44.000000000 +0200
++++ atm.dev/tn7dsl.c   2007-06-22 23:36:27.000000000 +0200
+@@ -2864,6 +2811,14 @@
+     dslhal_api_setRateAdaptFlag(pIhw, os_atoi(ptr));
+   }
++  // set powercutback
++  ptr = NULL;
++  ptr = prom_getenv("powercutback");
++  if(ptr)
++  {
++    dslhal_advcfg_onOffPcb(pIhw, os_atoi(ptr));
++  }
++
+   // trellis
+   ptr = NULL;
+   ptr = prom_getenv("trellis");
+--- atm.old/Makefile   2007-06-24 18:46:25.000000000 +0200
++++ atm.dev/Makefile   2007-06-24 18:46:31.000000000 +0200
+@@ -4,6 +4,7 @@
+ CONFIG_SANGAM_ATM=m
+ #EXTRA_CFLAGS += -DEL -I. -DPOST_SILICON -DCOMMON_NSP -DCONFIG_LED_MODULE -DDEREGISTER_LED -DNO_ACT
+-EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
++#EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -DNO_ACT -D__NO__VOICE_PATCH__ -DEL
++EXTRA_CFLAGS += -DEL -I$(PWD) -DPOST_SILICON -DCOMMON_NSP -D__NO__VOICE_PATCH__ -DEL
+ obj-$(CONFIG_SANGAM_ATM) := tiatm.o
+-tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o
++tiatm-objs += cpsar.o aal5sar.o tn7sar.o tn7atm.o tn7dsl.o dsl_hal_api.o dsl_hal_support.o dsl_hal_advcfg.o
+--- atm.old/dsl_hal_advcfg.c   2007-06-24 19:22:42.000000000 +0200
++++ atm.dev/dsl_hal_advcfg.c   2007-06-24 19:21:42.000000000 +0200
+@@ -36,9 +36,9 @@
+ *    05Jul05     0.00.09            CPH    CQ9775: Change dslhal_advcfg_configDsTones input parameters & support for ADSL2+
+ *    24Jul05     0.00.10            CPH    Fixed comments in dslhal_advcfg_configDsTones function header
+ *******************************************************************************/
+-#include <dev_host_interface.h>
+-#include <dsl_hal_register.h>
+-#include <dsl_hal_support.h>
++#include "dev_host_interface.h"
++#include "dsl_hal_register.h"
++#include "dsl_hal_support.h"
+ /*****************************************************************************/
+ /* ACT API functions -- To be moved into their own independent module --RamP */
diff --git a/package/ar7-atm/patches/140-debug_mode.patch b/package/ar7-atm/patches/140-debug_mode.patch
new file mode 100644 (file)
index 0000000..b09234f
--- /dev/null
@@ -0,0 +1,16 @@
+--- atm.old/tn7sar.c   2007-06-25 13:25:44.000000000 +0200
++++ atm.dev/tn7sar.c   2007-06-25 13:26:33.000000000 +0200
+@@ -102,10 +102,10 @@
+ #define RESERVED_OAM_CHANNEL              15
+-#define AAL5_PARM "id=aal5, base = 0x03000000, offset = 0, int_line=15, ch0=[RxBufSize=1522; RxNumBuffers = 32; RxServiceMax = 50; TxServiceMax=50; TxNumBuffers=32; CpcsUU=0x5aa5; TxVc_CellRate=0x3000; TxVc_AtmHeader=0x00000640]"
+-#define SAR_PARM "id=sar,base = 0x03000000, reset_bit = 9, offset = 0; UniNni = 0, PdspEnable = 1"
++#define CH0_PARM "RxBufSize=1522, RxNumBuffers=32, RxServiceMax=50, TxServiceMax=50, TxNumBuffers=32, CpcsUU=0x5aa5, TxVc_CellRate=0x3000, TxVc_AtmHeader=0x00000640"
++#define AAL5_PARM "id=aal5, base=0x03000000, offset=0, int_line=15, ch0=[" CH0_PARM "]"
++#define SAR_PARM "id=sar, base=0x03000000, reset_bit=9, offset=0; UniNni=0, PdspEnable=1, Debug=0xFFFFFFFF"
+ #define RESET_PARM "id=ResetControl, base=0xA8611600"
+-#define CH0_PARM "RxBufSize=1522, RxNumBuffers = 32, RxServiceMax = 50, TxServiceMax=50, TxNumBuffers=32, CpcsUU=0x5aa5, TxVc_CellRate=0x3000, TxVc_AtmHeader=0x00000640"
+ #define MAX_PVC_TABLE_ENTRY 16