[ixp4xx] move crypto module to target specific modules.mk
authorFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:50:16 +0000 (15:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 25 Jul 2012 15:50:16 +0000 (15:50 +0000)
SVN-Revision: 32856

package/kernel/modules/crypto.mk
target/linux/ixp4xx/modules.mk

index f9ce8f96da32120c174b8f837a5368b89ab13fa1..1e2214214816da40eaeb7ea933bad57574515c61 100644 (file)
@@ -154,23 +154,6 @@ endef
 $(eval $(call KernelPackage,crypto-hw-hifn-795x))
 
 
-define KernelPackage/crypto-hw-ixp4xx
-  TITLE:=Intel IXP4xx hardware crypto module
-  DEPENDS:=@TARGET_ixp4xx
-  KCONFIG:= \
-       CONFIG_CRYPTO_DEV_IXP4XX
-  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
-  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
-  $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
-endef
-
-define KernelPackage/crypto-hw-ixp4xx/description
-  Kernel support for the Intel IXP4xx HW crypto engine.
-endef
-
-$(eval $(call KernelPackage,crypto-hw-ixp4xx))
-
-
 define KernelPackage/crypto-hw-ppc4xx
   TITLE:=AMCC PPC4xx hardware crypto module
   DEPENDS:=@TARGET_ppc40x||TARGET_ppc44x
index e088497793baf10565f1b0e0da2d3265d17a431a..8bf6e693b7893a2460d7ddb8377b4c7f4473f510 100644 (file)
@@ -39,3 +39,20 @@ define KernelPackage/ixp4xx-beeper/description
 endef
 
 $(eval $(call KernelPackage,ixp4xx-beeper))
+
+
+define KernelPackage/crypto-hw-ixp4xx
+  TITLE:=Intel IXP4xx hardware crypto module
+  DEPENDS:=@TARGET_ixp4xx
+  KCONFIG:= \
+       CONFIG_CRYPTO_DEV_IXP4XX
+  FILES:=$(LINUX_DIR)/drivers/crypto/ixp4xx_crypto.ko
+  AUTOLOAD:=$(call AutoLoad,90,ixp4xx_crypto)
+  $(call AddDepends/crypto,+kmod-crypto-authenc +kmod-crypto-des)
+endef
+
+define KernelPackage/crypto-hw-ixp4xx/description
+  Kernel support for the Intel IXP4xx HW crypto engine.
+endef
+
+$(eval $(call KernelPackage,crypto-hw-ixp4xx))