add helper macro for stripping the last part of a version number
authorFelix Fietkau <nbd@openwrt.org>
Thu, 31 Jul 2008 23:55:39 +0000 (23:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 31 Jul 2008 23:55:39 +0000 (23:55 +0000)
SVN-Revision: 12054

rules.mk

index 5b411183c6e9b9ab3d7b9e882b5915d566d576b4..5a54c536d984d97a891c89d2928a8e5da4c2d639 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -27,6 +27,7 @@ empty:=
 space:= $(empty) $(empty)
 merge=$(subst $(space),,$(1))
 confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
+strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
 _SINGLE=MAKEFLAGS=$(space)
 ARCH:=$(call qstrip,$(shell echo $(CONFIG_ARCH) | sed -e 's/i[3-9]86/i386/'))