this patch fixes openssl parallel build.
authorTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 01:47:55 +0000 (01:47 +0000)
committerTravis Kemen <thepeople@openwrt.org>
Sun, 14 Mar 2010 01:47:55 +0000 (01:47 +0000)
-Raphael

SVN-Revision: 20186

package/openssl/Makefile

index ef0edb0daf2ff7bf1a8d9216c15d45a9e2984925..e7a74905fd00b950f5078f4362430c6e4b499fa8 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
 PKG_VERSION:=0.9.8m
 
 PKG_NAME:=openssl
 PKG_VERSION:=0.9.8m
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
@@ -18,8 +18,8 @@ PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=898bf125370926d5f692a2201124f8ec
 
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
 PKG_MD5SUM:=898bf125370926d5f692a2201124f8ec
 
-PKG_BUILD_DEPENDS := ocf-crypto-headers
-PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_ENGINE
+PKG_BUILD_DEPENDS:=ocf-crypto-headers
+PKG_CONFIG_DEPENDS:=CONFIG_OPENSSL_ENGINE
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -33,10 +33,10 @@ source "$(SOURCE)/Config.in"
 endef
 
 define Package/openssl/Default/description
 endef
 
 define Package/openssl/Default/description
- The OpenSSL Project is a collaborative effort to develop a robust,
- commercial-grade, full-featured, and Open Source toolkit implementing the
- Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1)
- protocols as well as a full-strength general purpose cryptography library.
+The OpenSSL Project is a collaborative effort to develop a robust,
+commercial-grade, full-featured, and Open Source toolkit implementing the Secure
+Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) protocols as well
+as a full-strength general purpose cryptography library.
 endef
 
 define Package/libopenssl
 endef
 
 define Package/libopenssl
@@ -50,8 +50,7 @@ endef
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
 
 define Package/libopenssl/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL shared libraries, needed by other
- programs.
+This package contains the OpenSSL shared libraries, needed by other programs.
 endef
 
 define Package/openssl-util
 endef
 
 define Package/openssl-util
@@ -68,7 +67,7 @@ endef
 
 define Package/openssl-util/description
 $(call Package/openssl/Default/description)
 
 define Package/openssl-util/description
 $(call Package/openssl/Default/description)
- This package contains the OpenSSL command-line utility.
+This package contains the OpenSSL command-line utility.
 endef
 
 
 endef
 
 
@@ -108,13 +107,20 @@ define Build/Compile
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
                depend
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
                depend
+       $(_SINGLE)$(MAKE) -C $(PKG_BUILD_DIR) \
+               CC="$(TARGET_CC)" \
+               AR="$(TARGET_CROSS)ar r" \
+               RANLIB="$(TARGET_CROSS)ranlib" \
+               OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
+               $(OPENSSL_MAKEFLAGS) \
+               all
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                AR="$(TARGET_CROSS)ar r" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
                $(OPENSSL_MAKEFLAGS) \
-               all build-shared
+               build-shared
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
        # Work around openssl build bug to link libssl.so with libcrypto.so.
        -rm $(PKG_BUILD_DIR)/libssl.so.*.*.*
        $(MAKE) -C $(PKG_BUILD_DIR) \
@@ -129,11 +135,11 @@ define Build/Compile
 endef
 
 define Build/InstallDev
 endef
 
 define Build/InstallDev
-       mkdir -p $(1)/usr/include
+       $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
-       mkdir -p $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
-       mkdir -p $(1)/usr/lib/pkgconfig
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef